WordPress.org

Make WordPress Core

Opened 10 months ago

Closed 10 months ago

Last modified 10 months ago

#45321 closed defect (bug) (invalid)

List view scrolls to the top when opening a specific post/page/feedback

Reported by: kevindelsh Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

This bug is related to WordPress.com back-end (e.g. https://wordpress.com/types/feedback/example.com or https://wordpress.com/posts/example.org)

Test environment:

  • Browser: Google Chrome 70.0.3538.77 (Official Build) (64-bit)
  • OS: Windows 10 Pro

How to reproduce:

1- Navigate to https://wordpress.com/posts/example.com
2- Scroll down a little bit so that the upper part of the content is out of view.
3- Click on a post to open it.
4- Close the post by clicking the "Close" button at the top left corner.
5- You will see that the list of posts has scrolled up all the way to the very top.

One could argue that this is "normal" behavior but the UI also hijacks Chrome's normal behavior. If you click on the browser's back button instead of clicking the Close button you will also see the very top of the page.

In addition, a "Close" button, implies that this is some sort of a window or overlay that will close and leave you with your list of posts in the exact way you had it in the first place.

Change History (2)

#1 follow-up: @ocean90
10 months ago

  • Focuses ui javascript administration removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hello @kevindelsh, welcome to WordPress Trac!

This Trac is only used for reporting bugs with the WordPress core software. For issues with the platform WordPress.com please try contacting their support at https://en.support.wordpress.com/. Thanks!

#2 in reply to: ↑ 1 @kevindelsh
10 months ago

Hey @ocean90, thank you for pointing that out! I was suspicious about reporting it here so asked in #core slack channel and made it bold that the issue is with WordPress.com and someone sent me to this link nonetheless. Now, it's clear!

Replying to ocean90:

Hello @kevindelsh, welcome to WordPress Trac!

This Trac is only used for reporting bugs with the WordPress core software. For issues with the platform WordPress.com please try contacting their support at https://en.support.wordpress.com/. Thanks!

Note: See TracTickets for help on using tickets.