WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#4535 closed defect (bug) (invalid)

problem with post/page passwords

Reported by: Denis-de-Bernardy Owned by:
Milestone: Priority: lowest
Severity: minor Version: 2.2.1
Component: General Keywords: reporter-feedback
Focuses: Cc:

Description

Quoting customer:

Next, this is a crazy one, but here it is. If you create two different posts and create two different passwords before publishing, then (only in IE), if lets say you view post #1 it will ask you to enter a password. Then you enter the password (and I'm sure it gets cached somewhere in WP). Then all is okay. But if you try to Edit or View the alternate page (with a different password) IE always shows and error on the page (just above the Start button).

Then of course if you go to that second view post and enter its password, then viewing and editing that page shows no errors on page, but if you then again return to the first page with a different password it shows errors on the page (whether you view or edit the post), because I guess the cache has a different saved password.

Change History (5)

comment:1 markjaquith7 years ago

I know it wasn't you who wrote the report, but maybe you can go back to the customer for clarification.

I have no idea what this means:

IE always shows and error on the page (just above the Start button).

What is the error?

comment:2 foolswisdom7 years ago

  • Milestone set to 2.4 (future)

comment:3 Nazgul7 years ago

  • Keywords reporter-feedback added

Some more info would indeed be appreciated.

I tried to reproduce this on trunk, but was unable to do so using the given description (using IE7).

comment:4 Denis-de-Bernardy6 years ago

  • Component changed from Administration to General
  • Milestone changed from 2.5 to 2.6
  • Priority changed from normal to lowest
  • Severity changed from normal to minor

Im afraid I can't get back to the guy, as I can't recall who it was and I've lost all the data from my previous (stolen) laptop. Nor can I test on my end, from lack of a Windows box.

My understanding, though, is this:

  1. create two password protected posts
  2. log off
  3. browse the first post
  4. (says he...) an error shows with the second post
  5. and vice versa

I'm guessing he was in fact meaning a javascript error. "Near the Start button" frequently means "in the status bar" in computer-illiterate jargon.

It _could_ have been that a javascript was broken on one or either of his pages, due to an ID or something along those lines that wasn't getting displayed from lack of displaying the content. Some users are very anal about javascript errors -- especially when they've no idea of what they're doing.

On the other hand, it could be that WP is generating a js error for the very same reason. Or the other way around: a js that references something that only gets displayed on the "enter your password" form when none gets displayed.

Anyway, if no js errors show up with the above procedure in the current version of WP using IE, just close the ticket.

comment:5 Nazgul6 years ago

  • Milestone 2.6 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Unable to reproduce this, so closing as invalid based on the suggestion by Denis-de-Bernardy.

Note: See TracTickets for help on using tickets.