WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 9 days ago

#45355 closed defect (bug) (invalid)

PDF preview image is only in black and white

Reported by: swb1192 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.9.8
Component: Media Keywords: reporter-feedback
Focuses: Cc:

Description

When a PDF with color is uploaded, the preview image is only in black and white. The preview generation should handle color as well to accurately preview the PDF.

Change History (4)

#1 @mikeschroder
2 years ago

  • Keywords reporter-feedback added
  • Type changed from feature request to defect (bug)

Hi @swb1192!

Thanks so much for the report. Color PDF thumbnails are supposed to be supported by WordPress, so I'm guessing something is probably off either with WordPress' processing of the particular PDF, or something to do with the server configuration (and/or how WordPress works with that configuration, of course!).

Would you mind providing an example PDF with the problem, if it's possible, so that I can try to reproduce the issue?

#2 @swb1192
2 years ago

Thanks Mike.

Here was the PDF: https://dqsus.com/wp-content/uploads/2018/11/Q4-Impact-2018-1.pdf

Hosting with WP Engine.

This ticket was mentioned in Slack in #core-media by antpb. View the logs.


9 days ago

#4 @antpb
9 days ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hey there @swb1192 ! Thank you for your report! I realize it's been 2 years since no response on this issue, but I've tested the provided pdf in a WP Engine environment with successful color previews. Is this still occurring? I've not been able to find any other instances of this happening so we will close this issue as invalid for now, but if this is still valid please feel free to leave a comment!

Note: See TracTickets for help on using tickets.