WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 7 months ago

#45372 closed defect (bug) (wontfix)

Add nofollow to the link to the comment form login page.

Reported by: ishitaka Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Comments Keywords: has-patch close
Focuses: Cc:

Description

Can we have rel="nofollow" added to this link please?

comment-template.php:

__( 'You must be <a href="%s">logged in</a> to post a comment.' ),

Attachments (1)

45372.patch (930 bytes) - added by mukesh27 7 months ago.
Patch

Download all attachments as: .zip

Change History (11)

#1 @mukesh27
7 months ago

  • Component changed from Login and Registration to Comments
  • Keywords has-patch 2nd-opinion added

If above fix needs to add in core software then try attached patch. if it's not needed then close this ticket.

Last edited 7 months ago by mukesh27 (previous) (diff)

@mukesh27
7 months ago

Patch

#2 @ishitaka
7 months ago

@mukesh27 thanks for your patch.
Your patch worked as what I wanted.

#3 @swissspidy
7 months ago

  • Keywords reporter-feedback added

Hi @ishitaka and welcome to Trac!

Can you please elaborate on why you think this is necessary? Search engines are discouraged to index the login page because of <meta name='robots' content='noindex,follow' /> anyway.

#4 @ishitaka
7 months ago

Hi @swissspidy

This link is displayed on the post page, so it can not be <meta name='robots' content='noindex,follow' />.
And I think that it is better not to index the login page.

#5 @swissspidy
7 months ago

@ishitaka What I meant is that the wp-login.php page itself contains <meta name='robots' content='noindex,follow' />. It is already protected from being indexed. Your proposed change would have no effect.

#7 @swissspidy
7 months ago

  • Keywords close added; 2nd-opinion reporter-feedback removed

Looking at that support thread, the issue is about the site https://answer-final.com/.

They have protected their login form using a special way: https://answer-final.com/wp-login.php. When you open that URL you'll get an error message and a 403 response code.

That's why Googlebot errors in that case. It's not something caused by WordPress or something that WordPress can mitigate.

Just google for "inurl:wp-login.php" and you won't find any WordPress login page indexed.

#8 @ishitaka
7 months ago

Because the login page is noindex, what about the idea that it is not necessary to dare follow?

#9 @ishitaka
7 months ago

Blocking access to wp-admin will result in a crawl error.

Last edited 7 months ago by ishitaka (previous) (diff)

#10 @SergeyBiryukov
7 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Closing per comment:7, as this appears to be an issue with a particular site, not with WordPress core.

The wp-login.php page already has the noindex tag, so the proposed change would have no effect.

Note: See TracTickets for help on using tickets.