WordPress.org

Make WordPress Core

#45382 closed defect (bug) (fixed)

Add ability to specify a different default editor font per locale

Reported by: mkaz Owned by:
Milestone: 5.0 Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: Cc:
PR Number:

Description

Allow translators to specifying a different default font based on the language/locale. The translator can specify a different Google font to load, and what the CSS font-family should be for different locales.

See PR at: https://github.com/WordPress/gutenberg/pull/11826/

Fixes issue: https://github.com/WordPress/gutenberg/issues/9891

Change History (3)

#1 @SergeyBiryukov
12 months ago

  • Component changed from General to Editor

#2 @mkaz
12 months ago

It looks like this ticket changes went in with [43919]

It probably can just be closed out as merged.

cc: @danielbachhuber

Last edited 12 months ago by SergeyBiryukov (previous) (diff)

#3 @SergeyBiryukov
12 months ago

  • Milestone changed from Awaiting Review to 5.0
  • Resolution set to fixed
  • Status changed from new to closed

Confirmed that [43919] does indeed include https://github.com/WordPress/gutenberg/pull/11826/.

Default editor font can now be adjusted per locale in translatable strings:

  • font_family = _x( 'Noto Serif:400,400i,700,700i', 'Google Font Name and Variants' );
  • $locale_font_family = esc_html_x( 'Noto Serif', 'CSS Font Family for Editor Font' );
Note: See TracTickets for help on using tickets.