WordPress.org

Make WordPress Core

Opened 11 months ago

Last modified 11 months ago

#45393 new defect (bug)

categories don't work in brand-new wordpress instance (return 404)

Reported by: awardpress Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.9.8
Component: Taxonomy Keywords:
Focuses: Cc:
PR Number:

Description

steps to reproduce:

  1. install new wordpress instance
  2. create a category test
  3. go to its url http://example.com/category/test/

(i also tried /category/test (without closing slash))

expected result:
http status 200, "no items found" message
NOTHING FOUND It seems we can’t find what you’re looking for. Perhaps searching can help.

actual result:
http status 404, "page not found" message
OOPS! THAT PAGE CAN’T BE FOUND. It looks like nothing was found at this location. Maybe try a search?

even if you continue:

  1. add a post to the category
  2. visit category page again

-- you'll get the same result.

workaround:

  1. switch theme to twenty fifteen
  2. switch back to twenty seventeen
  3. visit category page again

-- now you get the expected result, the bug won't reproduce anymore

versions:
PHP Version 5.6.38
Chromium Version 70.0.3538.77 (Official Build) Built on Ubuntu , running on Ubuntu 18.10 (64-bit)

Change History (1)

#1 @awardpress
11 months ago

EDIT:

if you did follow the steps 4--5, then the expected result would be accordingly:
http status 200, list of posts contained in that category (the list would consist of 1 single post added on step 4).

-- but everything else is the same as with an empty category

Note: See TracTickets for help on using tickets.