WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#45481 closed defect (bug) (reported-upstream)

Classic Block bold and italic

Reported by: lynxgd Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: Cc:

Description

When Posts in the Classic Block have bold or italic text set / unset there are a number of issues, intermittently, where text doesn't change style and / or the whole block becomes highlighted when the bold or italic button is clicked; and sometimes the originally highlighted text becomes unselectable until the cursor is clicked outside of the block.

Additionally, spaces between words can randomly disappear at either end of the selected text.

It happens most when you select text which is a mixture of styles (including spaces) but there seems to be a randomness to when it does and doesn't work properly.

Tested in WP5.0-RC3-43966 and previous versions with TwentyNineteen theme and all plugins disabled, on Mac 10.12.6, Firefox and Chrome.

Change History (5)

This ticket was mentioned in Slack in #core-editor by joyously. View the logs.


3 years ago

#2 follow-up: @lonelyvegan
3 years ago

Thanks for filing this issue!

If this can't be replicated with the Classic Editor and only with a Classic Block in Gutenberg then I wonder if this should be filed in the Gutenberg repository (https://github.com/WordPress/gutenberg/).

That said I wasn't able to reproduce the issue, I notice you said it was happening intermittently. Would you be able to record a video of it happening or present some concrete steps to reproduce the issue?

#3 in reply to: ↑ 2 @lynxgd
3 years ago

Replying to lonelyvegan:

Thanks for filing this issue!

If this can't be replicated with the Classic Editor and only with a Classic Block in Gutenberg then I wonder if this should be filed in the Gutenberg repository (https://github.com/WordPress/gutenberg/).

I've just tested in Classic Editor using the plugin and some of the same issues are present - unexpected non-toggling and spaces disappearing.

And switching to text view I can see that the Visual Editor has created nested strong tags, such as:

<strong>plants, our</strong><strong>concern<strong> is that</strong></strong><strong> economic arguments interfere with risk management.</strong>

which may be at the root of the problem?

That said I wasn't able to reproduce the issue, I notice you said it was happening intermittently. Would you be able to record a video of it happening or present some concrete steps to reproduce the issue?

It won't do it to order, the bold toggling will work as expected most of the time. I've been unable to identify what triggers the issue but using bold across a mix of bold and non-bold text seems to make it more likely to happen.

I have some screen recordings but not sure how clear they are, if you think they'd be useful I can try editing them or doing new ones to highlight points where things go wrong.

#4 @dmsnell
3 years ago

  • Resolution set to reported-upstream
  • Status changed from new to closed

@lynxgd thanks for filing this report. I'm going to close the ticket here to help other contributors and maintainers as they prioritize and address issues. why? well, because (a) it would be helpful to have this issue in the GitHub list of issues since it's related to the block editor code and (b) because I believe that the same core problem has already been noted in a few different existing issues.

instead of creating a new duplicate of this I'm going to fold it in to #12529, #12314, and #11743

you are welcome to comment again if you think I've misunderstood something. I think that when those issues are resolved (or when the root cause is dealt with) then this one will be fixed as well. thanks!

#5 @ocean90
3 years ago

  • Milestone Awaiting Review deleted
  • Version trunk deleted
Note: See TracTickets for help on using tickets.