WordPress.org

Make WordPress Core

#45523 closed enhancement (duplicate)

PHP 7.3.0 raises E_NOTICE when compact() parameters do not refer to an existing variable

Reported by: ettoredn Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

It appears that since PHP 7.3.0 compact() raises E_NOTICE when passed variable names are undefined.

PHP Notice: compact(): Undefined variable: post_status in wp-admin/includes/post.php on line 1059
PHP Notice: compact(): Undefined variable: perm in wp-admin/includes/post.php on line 1059
PHP Notice: compact(): Undefined variable: order in wp-admin/includes/post.php on line 1059
PHP Notice: compact(): Undefined variable: orderby in wp-admin/includes/post.php on line 1059

Steps to reproduce:

  1. Install WP 5.0.0
  2. set error_reporting = E_ALL
  3. Log in the admin interface.

I get the feeling there a few other similar situations across the WP codebase.

Change History (1)

#1 @ocean90
18 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 5.0 deleted

Duplicate of #45483.

Note: See TracTickets for help on using tickets.