WordPress.org

Make WordPress Core

#45545 closed defect (bug) (worksforme)

WP 5.0 Custom field Issue

Reported by: irfoxm Owned by:
Milestone: Priority: normal
Severity: critical Version: 5.0
Component: Options, Meta APIs Keywords:
Focuses: Cc:

Description

There is a major bug or issue with Custom field in WordPress 5.0 release. There is custom field in Post editor which also incorporate plugin custom entry, which is good but things wrong with custom field is that whatever entry you put in custom field is gone after saving draft or publish. So, I test it out with different plugin but problem with all is same, for ex- if put some text in custom field and click update below will save that text but when saving draft or publish it, things gone.

Change History (4)

#1 follow-up: @subrataemfluence
20 months ago

  • Keywords reporter-feedback added

Welcome to Trac and thanks for the ticket!

  • Is this a Custom Post Type you developed?
  • Are you using Block editor?
  • Is this a Gutenberg Block? If yes, are you using metaboxes?

It would be nice if you please put some more light on this.
Also can you post the exact steps to reproduce the issue?

Thanks!

#2 in reply to: ↑ 1 @irfoxm
20 months ago

Replying to subrataemfluence:

Welcome to Trac and thanks for the ticket!

  • Is this a Custom Post Type you developed?
  • Are you using Block editor?
  • Is this a Gutenberg Block? If yes, are you using metaboxes?

It would be nice if you please put some more light on this.
Also can you post the exact steps to reproduce the issue?

Thanks!

_
Hi There ! So my environment is running wp 5.0 latest and using Gutenberg. I have plugin installed that is custom post type to put things or entry.
In WP 5.0 Issue is on editing post screen and this path--- edit post screen >> more tools and options > Options > Advanced panels > custom fields. When Custom fields is marked, there appears entry box of custom fields > Add New Custom Field. This entry field is totally misbehaving, when I choose plugin field appears in dropdown and put things in the custom field and click on update will save things but when I publish post or save draft things all gone or blank. So this is all the problem is hope it will be fixed in the next release.
You dev team, and Gutenberg Release is great 👍.

#3 @desrosj
17 months ago

  • Keywords close added; needs-patch removed

Hi @irfoxm,

Thanks for creating this ticket!

I have been trying to find issues with custom fields, but I have been unable to break it. I am going to mark this as a candidate to close as it worksforme. If you are still experiencing this issue with the latest version of WordPress, can you please provide more detailed steps to reproduce the issue? Please ensure the issue you are experiencing is happening with all plugins disabled and the default TwentyNineteen theme.

#4 @desrosj
14 months ago

  • Keywords reporter-feedback close removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I am going to close this out due to lack of reporter feedback.

@irfoxm if you are still experiencing the issue you have described, please do reopen and provide more detailed instructions someone can use to reproduce the issue.

Note: See TracTickets for help on using tickets.