WordPress.org

Make WordPress Core

Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#45561 closed defect (bug) (invalid)

Cannot Edit Blog Post Draft

Reported by: flashmarketingsolutions Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0
Component: Posts, Post Types Keywords:
Focuses: administration Cc:
PR Number:

Description

Click edit on a draft
The edit page reverts to a blog post that is already published.

The post url does show the correct post ID but the content is not correct.

The content from the draft is not displayed. The content from the published post is displayed in stead of the draft.

Change History (2)

#1 @subrataemfluence
11 months ago

  • Focuses administration added; accessibility removed
  • Resolution set to invalid
  • Status changed from new to closed

Welcome to Trac and thanks for the ticket!

I could not reproduce the issue using your suggested steps. I saved two draft posts one through Block Editor and the other through Classic Editor. Both are loading with correct content using either of the editors.

If the issue is still persisting at your end I would suggest you to try deactivating all your plugins and try again.

I am closing this ticket for now. Please feel free to reopen with more information if you still encounter the issue.

#2 @SergeyBiryukov
11 months ago

  • Milestone Awaiting Review deleted

Hi @flashmarketingsolutions, welcome to WordPress Trac! Thanks for the report.

Issues like this are generally caused by the server forcibly setting Cache-Control for all pages, including the admin.

See comment:12:ticket:37889 for more details.

Note: See TracTickets for help on using tickets.