WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 weeks ago

Last modified 2 weeks ago

#45602 closed enhancement (fixed)

"Plugins API"-like approach for updates

Reported by: hecke29 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.8
Component: Plugins Keywords:
Focuses: Cc:

Description

Currently one can modify the installation- and search-process for plugins with applying filters for 'plugins_api'-filter (used in function plugins_api in wp-admin/includes/plugin-install.php).

This is not possible for the update process (function wp_update_plugins in wp-includes/update.php) that gather information for available updates.

I'd love to see a apply_filter for the response (instead) of wp_remote_post in the lastly mentioned function like in the mentioned plugins_api

Change History (3)

#1 @hecke29
3 weeks ago

  • Resolution set to worksforme
  • Status changed from new to closed
  • Version set to 5.8

Solved by [50921]

#2 @desrosj
2 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution changed from worksforme to duplicate

Duplicate of #14179.

#3 @desrosj
2 weeks ago

  • Resolution changed from duplicate to fixed

Sorry, not a true duplicate. Leaving closed as fixed by [50921].

Note: See TracTickets for help on using tickets.