WordPress.org

Make WordPress Core

Opened 22 months ago

Closed 13 months ago

Last modified 4 weeks ago

#45654 closed defect (bug) (worksforme)

Gutenberg Editor Preview Button not working for published or scheduled posts

Reported by: stevencannoodt Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0.1
Component: Editor Keywords:
Focuses: Cc:

Description

Dear WordPress.org,
I have noticed a problem when using the preview button on the new Gutenberg editor (WP 5.0.1). When a new post is created or when revising a draft post, the preview button works fine. However, on already published or scheduled posts to be published later, the preview button does not work (it seems to have a different post id in the URL of the preview tab that opens up and therefore goes to a 404 page I installed). however, when clicking the 'view post' in the top header, that works fine. This happens on a Mac, Google Chrome, WP 5.0.1, Theme: Divi.

Change History (3)

#1 @SergeyBiryukov
22 months ago

  • Component changed from General to Editor

#2 @pento
13 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to fixed
  • Status changed from new to closed

This appears to be working correctly in the Gutenberg plugin, so I'm going to close this ticket.

#3 @SergeyBiryukov
4 weeks ago

  • Resolution changed from fixed to worksforme

Just changing the resolution to worksforme for accuracy, as it's not quite clear when or where exactly this was fixed.

Note: See TracTickets for help on using tickets.