WordPress.org

Make WordPress Core

Opened 19 months ago

Closed 6 months ago

#45658 closed defect (bug) (duplicate)

get_post_thumbnail_id

Reported by: Tkama Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0.1
Component: Post Thumbnails Keywords:
Focuses: docs Cc:

Description (last modified by SergeyBiryukov)

I have some questions for function get_post_thumbnail_id():

  • why does it return a string instead of an integer?
  • why @return string|int in docs? It can't return an integer.

Change History (2)

#1 @SergeyBiryukov
19 months ago

  • Component changed from General to Post Thumbnails
  • Description modified (diff)
  • Focuses docs added
  • Type changed from feature request to defect (bug)

#2 @desrosj
6 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report, @Tkama. I am going to close this out as a duplicate of #40096 as that was a preexisting ticket for returning a string instead of integer.

Note: See TracTickets for help on using tickets.