WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#45664 closed defect (bug) (fixed)

Update `grunt-sass` to v3 and add `node-sass` v4

Reported by: netweb Owned by: jeremyfelt
Milestone: 5.1 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords: has-patch
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Following r44219 with the update of Node.js to v10.13.0 the grunt-sass package requires an updated binary for the v4.7.2 release for Node.js v10.x.

This is not available as node-sass v4.7.2 is ~13 months old and binaries were never created for this release of Node.js

The solution is to update to a newer version of node-sass that includes a Node.js 10.x binary, in this case v4.11.0

As grunt-sass no longer includes node-sass it is also installed and the implementation option added to the sass Grunt task for grunt-sass v3 compatibility.

See also Core Slack discussion: https://wordpress.slack.com/archives/C02RQBWTW/p1544927491907900

Attachments (1)

45664.diff (22.3 KB) - added by netweb 9 months ago.

Download all attachments as: .zip

Change History (5)

@netweb
9 months ago

#1 @netweb
9 months ago

  • Keywords has-patch added

This ticket was mentioned in Slack in #core by netweb. View the logs.


9 months ago

#3 @jeremyfelt
9 months ago

  • Owner set to jeremyfelt
  • Resolution set to fixed
  • Status changed from new to closed

In 44233:

Build Tools: Update grunt-sass to v3 and add node-sass v4.

This fixes an error in the PHP 5.2 and 5.3 Travis builds after [44219].

Props netweb.
See #45241.
Fixes #45664.

#4 @SergeyBiryukov
9 months ago

  • Description modified (diff)
  • Milestone changed from 5.0.2 to 5.1

Appears to be an issue in trunk only.

Note: See TracTickets for help on using tickets.