WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#45674 closed defect (bug) (reported-upstream)

Cannot select Separator block by clicking on it

Reported by: Sulli Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0.1
Component: Editor Keywords:
Focuses: ui, accessibility Cc:

Description

Hello,

I found a problem with separator block in the new content editor (Gutenberg).

To reproduce the bug : Insert a separator block with default short line or wide line style and click on other block to lost focus. Try to select again the separator block with your mouse, you will see that you can't.

Proposed solution : I inspected the separator block style and founded the div around hr tag is only 2px height so we can't select it. Just add more styles to hr (padding ?) or min-height to his parent...?
Several solutions are possible.

Note : Dots style is ok, the div around hr tag if 20px

Change History (4)

#1 @Sulli
2 years ago

  • Summary changed from Separator can't be focus selected with mouse to Separator block can't be selected with mouse

#2 @subrataemfluence
2 years ago

  • Summary changed from Separator block can't be selected with mouse to Cannot select Separator block by clicking on it

Welcome to Trac and thanks for opening the ticket!

Your observation is correct!

However, this issue is already being tracked at https://github.com/WordPress/gutenberg/issues/12080.

Since Gutenberg development and contributions are still being maintained in Github, I guess opening an issue there would be more helpful.

Since hovering over the block does allow us to access the block menu, I have modified the title.

#3 @SergeyBiryukov
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

#4 @Sulli
2 years ago

Thank you, we continue on Github

Note: See TracTickets for help on using tickets.