WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 20 months ago

#45678 closed defect (bug) (duplicate)

5.0.1 hyperlink function BUG

Reported by: otaniitai Owned by:
Milestone: Priority: normal
Severity: major Version: 5.0.1
Component: Editor Keywords: needs-testing
Focuses: Cc:

Description

After installing the new update 5.0.1, I tried over and over to add a hyperlink, using the link function in the toolbar, which would open a url in a new tab. Adding the hyperlink seemed random, as to whether the url would hyperlink, the hyperlinking box would be responsive or non responsive, or whether a successful link would open the url in a different tab. Something is wrong with the toolbar link system.

Change History (5)

#1 @SergeyBiryukov
2 years ago

  • Component changed from Toolbar to Editor

#2 @brianrshim
2 years ago

Same problem here using 5.0.2.

I'm using the new Block editor (Gutenberg) in Visual mode. Here are the steps to reproduce:

  • Highlight a section of text
  • Click the Chain button to create a link
  • Paste in the link address in the popup
  • Click the Gear icon
  • Check Open link in a new tab
  • Click Update button

Editor will jump to top of page and link will not be created in highlighted text.

#3 @brianrshim
2 years ago

Note, my previous comment applies to a pre-existing post that I opened with the Block editor but did NOT convert to blocks yet. Once you convert to blocks, the add link popups work properly.

#4 @verygoode
2 years ago

We have been discussing a similar issue, specifically with the Classic block, on the forums.

@andyvnguyen posted a video within that thread that appears to be the same issue @brianrshim detailed.


@otaniitai Were you utilizing the Classic block when this happened?

@brianrshim From your notes, it appears you were editing posts that were using the Classic block, correct?

#5 @pento
20 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This appears to be a duplicate of #46071, which was fixed in WordPress 5.1.

Please re-open this ticket if you're still able to reproduce it in the latest version of WordPress.

Note: See TracTickets for help on using tickets.