WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#4569 closed defect (bug) (worksforme)

rss widget is broken

Reported by: Denis-de-Bernardy Owned by: andy
Milestone: Priority: highest omg bbq
Severity: normal Version: 2.3
Component: Template Keywords: reporter-feedback
Focuses: Cc:

Description

needs:

$url = html_entity_decode($url);

Change History (12)

comment:1 Otto427 years ago

Would you care to be a bit more specific?

comment:2 technosailor7 years ago

I don't know his situation, but I would point out that if you do a Google Blog Search that includes a +, as an example, and try subscribing to the RSS feem the widget won't parse the URL. This tracks all the way back to the damn magpie library. But maybe his situation is different than mine.

comment:3 Nazgul7 years ago

  • Keywords reporter-feedback added

comment:4 foolswisdom7 years ago

  • Milestone 2.2.2 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing as invalid. Not enough information.

comment:5 Denis-de-Bernardy7 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version changed from 2.2.1 to 2.3

comment:6 ryan7 years ago

Related to #4411?

comment:7 Nazgul7 years ago

  • Milestone set to 2.4

comment:9 ryan7 years ago

#4411 is fixed for 2.3.1 and 2.4. In my testing, that fixes the MSN search example given here. You'll need to re-input the URL to get an unbutchered version in the DB.

comment:10 andy6 years ago

  • Owner changed from anonymous to andy
  • Status changed from reopened to new

comment:11 andy6 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Tested @6423 with following URL, worked flawlessly.

http://blogsearch.google.com/blogsearch_feeds?hl=en&tab=mb&q=andy+skelton&ie=utf-8&num=10&output=rss

comment:12 lloydbudd6 years ago

  • Milestone 2.4 deleted
Note: See TracTickets for help on using tickets.