WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 9 months ago

#45693 closed defect (bug) (fixed)

Twenty Nineteen: Update theme description and tags

Reported by: kjellr Owned by: laurelfulford
Milestone: 5.0.3 Priority: normal
Severity: normal Version: 5.0.1
Component: Bundled Theme Keywords: has-patch fixed-major
Focuses: Cc:

Description

The theme description currently in place for Twenty Nineteen was meant as a placeholder.

Twenty Nineteen is a Gutenberg-ready theme for WordPress.

This should be updated to the description that exists over on Twenty Nineteen's GitHub repo:

Our 2019 default theme is designed to show off the power of the block editor. It features custom styles for all the default blocks, and is built so that what you see in the editor looks like what you'll see on your website. Twenty Nineteen is designed to be adaptable to a wide range of websites, whether you’re running a photo blog, launching a new business, or supporting a non-profit. Featuring ample whitespace and modern sans-serif headlines paired with classic serif body text, it's built to be beautiful on all screen sizes.

In addition, the theme's tags are not consistent across readme.txt, style.css, and style-rtl.css. They need to sync up, and theme-options tag should be removed, since Twenty Nineteen does not utilize that customizer panel.

(This PR ports over the updates from Twenty Nineteen's GitHub repo: https://github.com/WordPress/twentynineteen/pull/710/ )

Attachments (1)

45693.patch (6.2 KB) - added by kjellr 9 months ago.

Download all attachments as: .zip

Change History (8)

@kjellr
9 months ago

#1 @laurelfulford
9 months ago

  • Keywords has-patch needs-testing added
  • Milestone changed from Awaiting Review to 5.0.3
  • Owner set to laurelfulford
  • Status changed from new to assigned

#2 @laurelfulford
9 months ago

  • Version set to 5.0.1

#3 @laurelfulford
9 months ago

  • Keywords needs-refresh added; needs-testing removed

Thank you for porting this over, @kjellr!

Right now 45693.patch is failing for me in all but style-rtl.css:

patching file src/wp-content/themes/twentynineteen/readme.txt
Hunk #1 FAILED at 8.
1 out of 1 hunk FAILED -- saving rejects to file src/wp-content/themes/twentynineteen/readme.txt.rej
patching file src/wp-content/themes/twentynineteen/style-rtl.css
patching file src/wp-content/themes/twentynineteen/style.css
Hunk #1 FAILED at 4.
1 out of 1 hunk FAILED -- saving rejects to file src/wp-content/themes/twentynineteen/style.css.rej
patching file src/wp-content/themes/twentynineteen/style.scss
Hunk #1 FAILED at 3.
1 out of 1 hunk FAILED -- saving rejects to file src/wp-content/themes/twentynineteen/style.scss.rej

I think it's just clashing with other minor changes in these files -- are you able to refresh this in the next day or so?

#4 @laurelfulford
9 months ago

  • Keywords needs-refresh removed

Removing needs-refresh -- I double-checked, and I can take care of cleaning up the patch before commit :)

#5 @laurelfulford
9 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 44377:

Twenty Nineteen: Update theme description and tags.

The original theme description in Twenty Nineteen was intended as a placeholder; this update replaces it with a proper description, and removes the unnecessary theme-options tag.

Props jobthomas, kjellr.
Fixes #45693.

#6 @SergeyBiryukov
9 months ago

  • Keywords fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for merging to the 5.0 branch.

#7 @SergeyBiryukov
9 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 44429:

Twenty Nineteen: Update theme description and tags.

The original theme description in Twenty Nineteen was intended as a placeholder; this update replaces it with a proper description, and removes the unnecessary theme-options tag.

Props jobthomas, kjellr.
Merges [44377] to the 5.0 branch.
Fixes #45693.

Note: See TracTickets for help on using tickets.