WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 3 months ago

#45736 closed defect (bug) (wontfix)

Twenty Nineteen: Hoefler Text too bold in Safari on El Capitan

Reported by: melchoyce Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-screenshots
Focuses: Cc:

Description (last modified by melchoyce)

At the very least, between Safari 9.1 and 11.1.2 on El Capitan.

No issues in Chrome or Firefox on El Capitan.

No issues in Safari on Mojave, or High Sierra.

First reported here: https://wordpress.org/support/topic/bold-fold-when-using-safari-11-1-2-under-el-capitan/

See attached screenshot.

Attachments (1)

screenshot-2019-theme.jpg (219.3 KB) - added by melchoyce 5 months ago.

Download all attachments as: .zip

Change History (5)

#1 @melchoyce
5 months ago

  • Description modified (diff)

#2 @laurelfulford
4 months ago

  • Keywords has-screenshots 2nd-opinion added

Thanks for the report, @melchoyce!

I can also recreate in El Capitan; on top of High Sierra and Mojave that you listed, Sierra also seems to be exempt.

I did a bit of searching and found some possibly related issues that indicate it's a problem with El Capitan:

https://discussions.apple.com/thread/7273258
https://bz.apache.org/ooo/show_bug.cgi?id=126363

... though no work around. I'm not sure of a good way to fix this that doesn't seem like overkill: like adding some kind of browser sniffing, or changing the first font in the font stack, and consequently, the appearance of the theme for everyone.

I'm leaning towards a wontfix here, but would appreciate a second opinion.

/cc @davidakennedy @kjellr & @allancole -- your thoughts would be appreciated!

#3 @kjellr
4 months ago

Wow, that's a really annoying bug! It's too bad Safari won't fall back to one of the other fonts in the stack when the standard Hoefler Text isn't available. I'm also not totally sure what we can do here — I don't know if we can even sniff out the OS version to implement a fallback in the first place. I'm also leaning towards wontfix unfortunately.

#4 @laurelfulford
3 months ago

  • Keywords 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Thanks for chiming in on this @kjellr!

It's too bad Safari won't fall back to one of the other fonts in the stack when the standard Hoefler Text isn't available.

I think the issue is that Hoefler Text is available -- the font itself is just messed up in that specific version of OSX and Safari for some reason. Really annoying indeed! :)

I'm going to close this as a wontfix.

Note: See TracTickets for help on using tickets.