WordPress.org

Make WordPress Core

Opened 22 months ago

Closed 5 weeks ago

Last modified 5 weeks ago

#45740 closed defect (bug) (invalid)

Cannot switch to Visual mode on a specific page

Reported by: johndroz Owned by:
Milestone: Priority: normal
Severity: major Version: 5.0.2
Component: Editor Keywords:
Focuses: Cc:

Description

I was updating (editing) a page, and it suddenly would not go back to “visual” mode. Instead when I toggled it went from HTML to Custom HTML!

I removed all plugins but the problem continued.

I have WP 5.0.2 and Genesis w Metric Child theme. I believe everything is up-to-date.

BTW, when I go to other pages on my website, I am able to toggle back and forth between Visual and HTML. Somehow on this one page, something got corrupted in the editor. I am able to make changes, and that is what I'm doing (via HTML).

BTW2, I tried starting with a brand new page, but ran into issues with the Blocks. For instance, I want to do something to a larger section of the page, but appear to be restricted to just dealing with individual blocks — not friendly. Further, how does one do something simple like indent a block? It's not apparent.

The page where I'm having issues with the editor is <http://wiseenergy.org/offshore-wind/>.

Help!

Change History (3)

This ticket was mentioned in Slack in #core by noisysocks. View the logs.


5 weeks ago

#2 @markparnell
5 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @johndroz thanks for the report, and sorry it's taken a while for anyone to get back to you.

It sounds like you may have ended up with an error in your HTML code, perhaps related to comments (<!-- -->) which is what the editor uses to mark up the blocks. It's certainly not clear how to reproduce the issue.

For future reference this would have been better asked on the forums, as it seems to be specific to your site.

As to the other concerns you had around using the block editor, hopefully the experience has improved in the last 20 months! If you still have any specific issues or suggestions, please feel free to open an issue in the Gutenberg Github repository. :-)

#3 @SergeyBiryukov
5 weeks ago

  • Keywords needs-patch removed
  • Summary changed from Editing Bug to Cannot switch to Visual mode on a specific page
Note: See TracTickets for help on using tickets.