WordPress.org

Make WordPress Core

#45757 closed defect (bug) (duplicate)

Plugin that registers new embed handler cannot get editor preview in core, but can with Gutenberg plugin

Reported by: notnownikki Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0.2
Component: Editor Keywords:
Focuses: Cc:

Description

This seems to be an issue with plugins that use wp_embed_register_handler to add more embed handlers.

I tested the plugin at https://wordpress.org/plugins/soundfaith-embed/ which provides an embed handler for faithlife.com

If you use the plugin version of Gutenberg, the editor works fine and the default embed block provides a preview of the embed, as expected.

If you just use core WordPress, the oembed proxy returns a 404.

Tested with 5.0.2, embedding https://sermons.faithlife.com/sermons/334709-the-gift-of-peace

Change History (1)

#1 @swissspidy
14 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #45447.

Note: See TracTickets for help on using tickets.