WordPress.org

Make WordPress Core

#45758 closed defect (bug) (invalid)

Open my articles and out error Cannot read property 'select' of undefined

Reported by: vluongo Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0.1
Component: Editor Keywords: reporter-feedback
Focuses: Cc:
PR Number:

Description

TypeError: Cannot read property 'select' of undefined
    at https://www.luongovincenzo.it/blog/wp-includes/js/dist/editor.min.js:55:120501
    at n.value (https://www.luongovincenzo.it/blog/wp-includes/js/dist/data.min.js:1:14919)
    at new n (https://www.luongovincenzo.it/blog/wp-includes/js/dist/data.min.js:1:14614)
    at zf (https://www.luongovincenzo.it/blog/wp-includes/js/dist/vendor/react-dom.min.js:69:258)
    at Mf (https://www.luongovincenzo.it/blog/wp-includes/js/dist/vendor/react-dom.min.js:87:4)
    at ph (https://www.luongovincenzo.it/blog/wp-includes/js/dist/vendor/react-dom.min.js:98:474)
    at eg (https://www.luongovincenzo.it/blog/wp-includes/js/dist/vendor/react-dom.min.js:125:307)
    at fg (https://www.luongovincenzo.it/blog/wp-includes/js/dist/vendor/react-dom.min.js:126:168)
    at wc (https://www.luongovincenzo.it/blog/wp-includes/js/dist/vendor/react-dom.min.js:138:237)
    at gg (https://www.luongovincenzo.it/blog/wp-includes/js/dist/vendor/react-dom.min.js:135:160)

Change History (5)

#1 @mukesh27
11 months ago

  • Component changed from General to Editor
  • Keywords reporter-feedback added
  • Version changed from 5.0.2 to 5.0.1

Hi @vluongo, welcome to WordPres Trac! Thanks for the report.

Does the issue still happen with all plugins disabled and a default theme (Twenty Nineteen) activated?

Could you provide the steps to reproduce the issue on a clean install?

#2 follow-up: @vluongo
11 months ago

hi @mukesh27 ,

in local env i have not a problem (latest wordpress version, all my plugins installed and my theme installed).
Now out other error, this is a complete console.log():

Uncaught TypeError: Cannot read property 'hasClass' of undefined
    at HTMLDocument.<anonymous> (wp-auth-check.min.js:1)
    at HTMLDocument.dispatch (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:3)
    at HTMLDocument.r.handle (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:3)
    at Object.trigger (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:3)
    at Object.a.event.trigger (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:9)
    at HTMLDocument.<anonymous> (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:3)
    at Function.each (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:2)
    at a.fn.init.each (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:2)
    at a.fn.init.trigger (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:3)
    at Object.<anonymous> (load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,heartbeat,jquery-ui-sortable,postbox,underscore,backbone,wp-util,wp-backbone,media-models,wp-pluplo&load[]=ad,wp-mediaelement,wp-api-request,media-views&ver=5.0.2:4)
(anonymous) @ wp-auth-check.min.js:1
dispatch @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:3
r.handle @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:3
trigger @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:3
a.event.trigger @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:9
(anonymous) @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:3
each @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:2
each @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:2
trigger @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:3
(anonymous) @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,heartbeat,jquery-ui-sortable,postbox,underscore,backbone,wp-util,wp-backbone,media-models,wp-pluplo&load[]=ad,wp-mediaelement,wp-api-request,media-views&ver=5.0.2:4
i @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:2
fireWith @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:2
y @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:4
c @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:4
XMLHttpRequest.send (async)
(anonymous) @ VM2721:1
send @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:4
ajax @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:4
j @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,heartbeat,jquery-ui-sortable,postbox,underscore,backbone,wp-util,wp-backbone,media-models,wp-pluplo&load[]=ad,wp-mediaelement,wp-api-request,media-views&ver=5.0.2:4
k @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,heartbeat,jquery-ui-sortable,postbox,underscore,backbone,wp-util,wp-backbone,media-models,wp-pluplo&load[]=ad,wp-mediaelement,wp-api-request,media-views&ver=5.0.2:4
m @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,heartbeat,jquery-ui-sortable,postbox,underscore,backbone,wp-util,wp-backbone,media-models,wp-pluplo&load[]=ad,wp-mediaelement,wp-api-request,media-views&ver=5.0.2:4
(anonymous) @ load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,heartbeat,jquery-ui-sortable,postbox,underscore,backbone,wp-util,wp-backbone,media-models,wp-pluplo&load[]=ad,wp-mediaelement,wp-api-request,media-views&ver=5.0.2:4
dispatch @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:3
r.handle @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=5.0.2:3
react-dom.min.js:104 TypeError: Cannot read property 'select' of undefined
    at edit-post.min.js:12
    at n.value (data.min.js:1)
    at new n (data.min.js:1)
    at zf (react-dom.min.js:69)
    at Mf (react-dom.min.js:87)
    at ph (react-dom.min.js:98)
    at eg (react-dom.min.js:125)
    at fg (react-dom.min.js:126)
    at wc (react-dom.min.js:138)
    at fa (react-dom.min.js:137)
Pf @ react-dom.min.js:104
Xf.f.function.f.componentDidCatch.c.callback @ react-dom.min.js:113
uf @ react-dom.min.js:65
tf @ react-dom.min.js:65
zc @ react-dom.min.js:146
wc @ react-dom.min.js:138
fa @ react-dom.min.js:137
gg @ react-dom.min.js:135
Ca @ react-dom.min.js:133
enqueueSetState @ react-dom.min.js:191
q.setState @ react.min.js:20
value @ data.min.js:1
(anonymous) @ data.min.js:1
n @ data.min.js:1
(anonymous) @ data.min.js:1
b @ data.min.js:1
(anonymous) @ data.min.js:1
(anonymous) @ data.min.js:1
(anonymous) @ redux-routine.min.js:1
dispatch @ data.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
Promise.then (async)
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
n.any @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
n.any @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
n.any @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
Promise.then (async)
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
t @ redux-routine.min.js:1
n.iterator @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
n.any @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
t @ redux-routine.min.js:1
n.iterator @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
t @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ data.min.js:1
tryCatch @ wp-polyfill.min.js:3
invoke @ wp-polyfill.min.js:3
t.(anonymous function) @ wp-polyfill.min.js:3
n @ data.min.js:1
c @ data.min.js:1
(anonymous) @ data.min.js:1
(anonymous) @ data.min.js:1
w @ data.min.js:1
(anonymous) @ data.min.js:1
fulfill @ data.min.js:1
(anonymous) @ data.min.js:1
tryCatch @ wp-polyfill.min.js:3
invoke @ wp-polyfill.min.js:3
t.(anonymous function) @ wp-polyfill.min.js:3
n @ data.min.js:1
c @ data.min.js:1
(anonymous) @ data.min.js:1
(anonymous) @ data.min.js:1
a @ data.min.js:1
(anonymous) @ data.min.js:1
(anonymous) @ data.min.js:1
(anonymous) @ edit-post.min.js:12
n @ data.min.js:1
r @ data.min.js:1
zf @ react-dom.min.js:69
Mf @ react-dom.min.js:87
ph @ react-dom.min.js:98
eg @ react-dom.min.js:125
fg @ react-dom.min.js:126
wc @ react-dom.min.js:138
fa @ react-dom.min.js:137
gg @ react-dom.min.js:135
Ca @ react-dom.min.js:133
og @ react-dom.min.js:150
Rd @ react-dom.min.js:150
bb.render @ react-dom.min.js:200
(anonymous) @ react-dom.min.js:153
mg @ react-dom.min.js:148
Bc @ react-dom.min.js:153
render @ react-dom.min.js:202
$n @ edit-post.min.js:12
(anonymous) @ post.php?post=967&action=edit:1970
react-dom.min.js:104 TypeError: Cannot read property 'select' of undefined
    at editor.min.js:55
    at n.value (data.min.js:1)
    at new n (data.min.js:1)
    at zf (react-dom.min.js:69)
    at Mf (react-dom.min.js:87)
    at ph (react-dom.min.js:98)
    at eg (react-dom.min.js:125)
    at fg (react-dom.min.js:126)
    at wc (react-dom.min.js:138)
    at fa (react-dom.min.js:137)
Pf @ react-dom.min.js:104
Xf.f.function.f.componentDidCatch.c.callback @ react-dom.min.js:113
uf @ react-dom.min.js:65
tf @ react-dom.min.js:65
zc @ react-dom.min.js:146
wc @ react-dom.min.js:138
fa @ react-dom.min.js:137
gg @ react-dom.min.js:135
Ca @ react-dom.min.js:133
enqueueSetState @ react-dom.min.js:191
q.setState @ react.min.js:20
value @ data.min.js:1
(anonymous) @ data.min.js:1
n @ data.min.js:1
(anonymous) @ data.min.js:1
b @ data.min.js:1
(anonymous) @ data.min.js:1
(anonymous) @ data.min.js:1
(anonymous) @ redux-routine.min.js:1
dispatch @ data.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
Promise.then (async)
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
n.any @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
n.any @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
n.any @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
Promise.then (async)
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
t @ redux-routine.min.js:1
n.iterator @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
n.any @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
t @ redux-routine.min.js:1
n.iterator @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
r @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
t @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ redux-routine.min.js:1
(anonymous) @ data.min.js:1
tryCatch @ wp-polyfill.min.js:3
invoke @ wp-polyfill.min.js:3
t.(anonymous function) @ wp-polyfill.min.js:3
n @ data.min.js:1
c @ data.min.js:1
(anonymous) @ data.min.js:1
(anonymous) @ data.min.js:1
w @ data.min.js:1
(anonymous) @ data.min.js:1
fulfill @ data.min.js:1
(anonymous) @ data.min.js:1
tryCatch @ wp-polyfill.min.js:3
invoke @ wp-polyfill.min.js:3
t.(anonymous function) @ wp-polyfill.min.js:3
n @ data.min.js:1
c @ data.min.js:1
(anonymous) @ data.min.js:1
(anonymous) @ data.min.js:1
a @ data.min.js:1
(anonymous) @ data.min.js:1
(anonymous) @ data.min.js:1
(anonymous) @ edit-post.min.js:12
n @ data.min.js:1
r @ data.min.js:1
zf @ react-dom.min.js:69
Mf @ react-dom.min.js:87
ph @ react-dom.min.js:98
eg @ react-dom.min.js:125
fg @ react-dom.min.js:126
wc @ react-dom.min.js:138
fa @ react-dom.min.js:137
gg @ react-dom.min.js:135
Ca @ react-dom.min.js:133
og @ react-dom.min.js:150
Rd @ react-dom.min.js:150
bb.render @ react-dom.min.js:200
(anonymous) @ react-dom.min.js:153
mg @ react-dom.min.js:148
Bc @ react-dom.min.js:153
render @ react-dom.min.js:202
$n @ edit-post.min.js:12
(anonymous) @ post.php?post=967&action=edit:1970
react-dom.min.js:104 TypeError: Cannot read property 'select' of undefined
    at editor.min.js:55
    at n.value (data.min.js:1)
    at new n (data.min.js:1)
    at zf (react-dom.min.js:69)
    at Mf (react-dom.min.js:87)
    at ph (react-dom.min.js:98)
    at eg (react-dom.min.js:125)
    at fg (react-dom.min.js:126)
    at wc (react-dom.min.js:138)
    at fa (react-dom.min.js:137)

#3 in reply to: ↑ 2 ; follow-up: @mukesh27
11 months ago

Does the issue still happen with all plugins disabled and a default theme (Twenty Nineteen) activated?

Could you provide the steps to reproduce the issue on a clean install?

Replying to vluongo:

in local env i have not a problem (latest wordpress version, all my plugins installed and my theme installed).
Now out other error, this is a complete console.log():

#4 in reply to: ↑ 3 @vluongo
11 months ago

I can not reproduce the problem with a clean installation

Replying to mukesh27:

Does the issue still happen with all plugins disabled and a default theme (Twenty Nineteen) activated?

Could you provide the steps to reproduce the issue on a clean install?

Replying to vluongo:

in local env i have not a problem (latest wordpress version, all my plugins installed and my theme installed).
Now out other error, this is a complete console.log():

#5 @SergeyBiryukov
11 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Severity changed from major to normal
  • Status changed from new to closed

Hi there, welcome to WordPress Trac! thanks for the report.

If the issue cannot be reproduced on a clean install, please try the support forums for further troubleshooting.

Free free to reopen with more details if it turns out to be an issue in WordPress core.

Note: See TracTickets for help on using tickets.