WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#4576 closed enhancement (fixed)

Jquery 1.1.3

Reported by: Mike_Koepke Owned by:
Milestone: 2.3 Priority: normal
Severity: normal Version: 2.2.1
Component: Optimization Keywords: jquery
Focuses: Cc:

Description

jquery 1.1.3 was released. They are claiming 800% performance improvement.

http://jquery.com/blog/2007/07/01/jquery-113-800-faster-still-20kb/

Change History (4)

#1 @intoxination
10 years ago

+1 for getting this in asap. Just tested it against 1.1.2 and there is a huge performance increase. Also I haven't found anything that breaks with the new version, so adding it should be simple.

(ps - Jquery site has been dugg, so a lot isn't accessible right now)

#2 @markjaquith
10 years ago

That's a heck of an upgrade (features and speed) for a x.x.y release. :-)

#3 @matt
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5775]) Upgrade to jQuery 1.1.3, fixes #4576

#4 @intoxination
10 years ago

We might want to hold off on this. JQuery 1.1.3.1 came out last week. There is still a problem in it though. Just loading the library will cause versions of Safari >2.0 to crash.

http://jquery.com/blog/2007/07/05/jquery-1131/

The other option would be to use the latest nightly of Jquery, which the problem is fixed in.

Note: See TracTickets for help on using tickets.