WordPress.org

Make WordPress Core

#45765 closed defect (bug) (fixed)

Not able to cancel update popup

Reported by: abhayvishwakarma Owned by: desrosj
Milestone: 5.1 Priority: normal
Severity: normal Version: 4.8
Component: Plugins Keywords: has-screenshots has-patch
Focuses: javascript Cc:
PR Number:

Description

When I goto Tools->Import and try to install any plugin for importing data, it shows popup which does not get closed.
Please refer the image
https://drive.google.com/file/d/1Uh84AuWvKBu_CfaolL4fpMzoJg7hXFep/view?usp=sharing

Attachments (3)

screenshot-av.com-2018.12.25-17-48-50.png (127.1 KB) - added by abhayvishwakarma 13 months ago.
2018-12-25-183104_1366x768_scrot.png (181.8 KB) - added by abhayvishwakarma 13 months ago.
Screenshot#2
45765.diff (1.8 KB) - added by afercia 13 months ago.

Download all attachments as: .zip

Change History (14)

#1 @abhayvishwakarma
13 months ago

WordPress Version 5.0.2

#2 @fahimmurshed
13 months ago

Hi,
Welcome here.

Looks you have permission error on the site.

Add this code to the WordPress wp-config.php file.

define('FS_METHOD', 'direct');

Check this screenshot:
https://i.imgur.com/sA4rwve.png

Your problem will be solved.

Let me know it works or not.

Last edited 13 months ago by fahimmurshed (previous) (diff)

#3 @abhayvishwakarma
13 months ago

I know that we can use this constant, but the issue is with the popup.
Please see the Screenshot2

Last edited 13 months ago by abhayvishwakarma (previous) (diff)

#4 @afercia
13 months ago

  • Component changed from General to Plugins
  • Focuses javascript added
  • Keywords has-screenshots needs-patch added
  • Milestone changed from Awaiting Review to 5.1
  • Version set to 4.8

The JS error Uncaught TypeError: Cannot read property 'replace' of undefined happens when trying to close the modal, either by clicking on the "Cancel" button or when clicking outside of the modal.

Seems to me this error has been introduced in WP 4.8, couldn't reproduce in 4.7.

#5 @afercia
13 months ago

Seems to me [40034] changed the l10n string installNowLabel to pluginInstallNowLabel but installNowLabel is still used for the importers.

@afercia
13 months ago

#6 @afercia
13 months ago

  • Keywords has-patch added; needs-patch removed
  • Milestone changed from 5.1 to 5.0.3

45765.diff uses pluginInstallNowLabel and updates the default string for consistency.

#7 @abhayvishwakarma
13 months ago

Hi @afercia,
I am using WordPress Version 5.0.2

#8 @desrosj
13 months ago

I was able to reproduce this on 5.0.2. 45765.diff fixed the issue for me. @abhayvishwakarma are you able to test this patch and confirm? Otherwise, looks good!

This ticket was mentioned in Slack in #core by desrosj. View the logs.


13 months ago

#10 @desrosj
13 months ago

  • Milestone changed from 5.0.3 to 5.1
  • Owner set to desrosj
  • Status changed from new to assigned

5.1 will be released shortly after 5.0.3, and as this is not within the 5.0.3 focuses (block editor bugs, regressions, and major bugs), it can wait.

#11 @SergeyBiryukov
13 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 44417:

Importers: Use correct l10n variable in wp.updates.installImporterError and filesystem credentials dialog.

Missed in [40034].

Props afercia, abhayvishwakarma.
Fixes #45765.

Note: See TracTickets for help on using tickets.