WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#45787 closed defect (bug) (duplicate)

(Font Upload)Sorry, this file type is not permitted for security reasons.

Reported by: afrooz Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0.2
Component: Upload Keywords:
Focuses: Cc:

Description

Dear Support Team,
I am using BeTheme v17 and my site has been automatically upgraded to wordpress 5.0.2 .
I have encountered a problem with uploading fonts, causing error (Sorry, this file type is not permitted for security reasons.)
since this issue is new, and I had uploaded fonts earlier with no problem, I'm guessing the error could be a bug in wordpress latest release.

I'd be appreciated if you could help me through this issue. I don't want to try the solutions that are available in the internet such as "Add ALLOW_UNFILTERED_UPLOADS constant to wp-config.php" because I don't want to put my site at a great risk of getting hacked.

Regards,
Afrooz Rashedi

Change History (2)

#1 @audrasjb
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Hello @afrooz, welcome to WordPress Trac and thank you for your ticket :-)

The issue described here affects several different file types, but there is a common cause which is already handled in #45615. I am going to close this ticket as duplicate.

More information here: https://make.wordpress.org/core/2018/12/13/backwards-compatibility-breaks-in-5-0-1/

#2 @SergeyBiryukov
4 months ago

  • Component changed from General to Upload
Note: See TracTickets for help on using tickets.