WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#45793 closed defect (bug) (invalid)

Month name is incorrectly abbreviated for English (UK) locale

Reported by: reddalek Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0.2
Component: Date/Time Keywords:
Focuses: Cc:

Description

Steps to reproduce:

  1. Set the Site Language to 'English (UK)'
  2. Set the Date Format to 'jS F Y'

Expected result: 30th December 2018
Actual result: 30th Dec 2018

This is not observed if Site Language is 'English (United States)' where the 'F' will correctly print the full month name.

Attachments (4)

45793-settings.PNG (25.6 KB) - added by RMarks 7 months ago.
uk.PNG (91.3 KB) - added by reddalek 7 months ago.
Abbreviation showing for UK locale
us.PNG (107.2 KB) - added by reddalek 7 months ago.
Abbreviation not showing for US locale
uk2.PNG (92.3 KB) - added by reddalek 7 months ago.
Mix of abbreviated and non-abbreviated month

Download all attachments as: .zip

Change History (9)

#1 @RMarks
7 months ago

Hello @reddalek, thank you for opening this ticket.

I've tried to reproduce this issue since I thought this might be an easy fix. I'm not seeing the same thing you are though. While on the Admin page Settings > General, I see the format as included in my screenshot (see below).

Would you please send a screenshot that shows the date using the abbreviated date?

Ryan

#2 @reddalek
7 months ago

Thanks for taking a look @RMarks!

I'm attaching three screenshots. You can see the month abbreviation used in the 'UK' setting, the full month for the 'US' setting, and (very weirdly) a mixture of the abbreviated and full month for the UK if I use a double F code. Let me know if there's more information which would be helpful.

@reddalek
7 months ago

Abbreviation showing for UK locale

@reddalek
7 months ago

Abbreviation not showing for US locale

@reddalek
7 months ago

Mix of abbreviated and non-abbreviated month

#3 @RMarks
7 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Hi again @reddalek,

I'm unable to reproduce this in a local development environment (VVV) or a production environment (Digital Ocean/Ubuntu/nginx), both running 5.0.2 and English (UK).

I'm curious, as you manually change the Custom date field, does the preview show the issue before you press Save Changes at the bottom?

#4 @reddalek
7 months ago

Hi @RMarks,

"I'm curious, as you manually change the Custom date field, does the preview show the issue before you press Save Changes at the bottom?"

Yes.

However, I just noticed that the issue didn't appear on another Wordpress installation I manage, so I just used the 'Re-install Now' option on the Updates page and that has magically fixed the issue.

I'm sorry for taking up your time...!

#5 @netweb
7 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.