WordPress.org

Make WordPress Core

Opened 10 months ago

Closed 3 months ago

#45798 closed defect (bug) (invalid)

In Gutenberg, Contributor role can Publish articles

Reported by: rexxertt Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords: reporter-feedback
Focuses: Cc:
PR Number:

Description

I have a brand new WordPress install and it comes with Gutenberg. After fully understanding the role permmissions and assigning them properly, i have discovered several of my writers assigned as Contributor with the ability to Publish articles.

Please advise

Change History (4)

#1 @RMarks
10 months ago

Hello @rexxertt, welcome to WordPress Trac and thank you for your ticket :-)

I've tried to reproduce this using two different environments running WordPress 5.0.2. In both scenarios, after creating a new post with the Block Editor, I'm able to click Publish which changes to Submit for Review. After clicking Submit for Review, the post status changes to Pending. As a user with Contributor access, I'm unable to find a way to publish the post.

Could you please provide the steps your Contributor writers used to publish a post?

Thank you,
Ryan

#2 @subrataemfluence
10 months ago

  • Keywords reporter-feedback added

#3 @SergeyBiryukov
9 months ago

  • Component changed from Role/Capability to Editor
  • Severity changed from major to normal

#4 @pento
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing this ticket, as we're unable to reproduce this issue.

Note: See TracTickets for help on using tickets.