Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#45823 closed defect (bug) (invalid)

Custom HTML block editor stripping HTML tags

Reported by: streetlogics's profile streetlogics Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0.2
Component: Editor Keywords:
Focuses: Cc:

Description

I was using the Gutenberg editor prior to the 5.0.0 upgrade and was able to insert iframe and script tags via custom html blocks. Now that I've upgraded to 5.0.X, I can no longer create a custom HTML block with iframe or script tags. Is there a way I can change the way it's apparently stripping HTML tags from my custom HTML blocks? I'm unsure if this issue is in the new codex or a problem with Gutenberg, so I'm submitted the ticket in both places. This feels a little heavy handed, and incredibly odd and frustrating that this was working just fine prior to the "official" upgrade to use Gutenberg as the default editor. As a web developer, I expect to have 100% control over things like "custom HTML blocks" without having the editor interfere.

Change History (3)

#1 @streetlogics
5 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

Realized I was editing with a non-admin user, admin users can upload custom html content of any type no issues.

#2 @peterwilsoncc
5 years ago

  • Milestone Awaiting Review deleted

#3 @swissspidy
5 years ago

  • Resolution changed from wontfix to invalid
  • Severity changed from blocker to normal
Note: See TracTickets for help on using tickets.