Make WordPress Core

Opened 5 years ago

Closed 5 weeks ago

#45923 closed enhancement (worksforme)

Twenty Nineteen: When site tagline is empty, hide the "—" divider in the customizer.

Reported by: kjellr's profile kjellr Owned by:
Milestone: Priority: lowest
Severity: normal Version: 5.0.2
Component: Bundled Theme Keywords: close
Focuses: Cc:

Description

As originally noted by in the Twenty Nineteen GitHub repository:

https://github.com/WordPress/twentynineteen/issues/451

Twenty Nineteen uses an em dash to divide the site title from the tagline. On the front end, this em dash is hidden when there's no tagline. This is not the case in the Customizer:

https://cldup.com/-1J82JUUwg-3000x3000.png

Note that this is only visible if the edit shortcuts are hidden for some reason. Otherwise, they overlap the em dash, and the issue is not visible.

https://cldup.com/ubdUrcBnpZ-3000x3000.png

Since the likelihood the em dash would be visible in this context is so low, I'm marking this as an enhancement rather than a bug.

Change History (2)

#1 @sabernhardt
10 months ago

  • Keywords close added

As part of the proposal to retire default themes, Twenty Nineteen might not have any more enhancements soon.

Also, I think the odd occasion when the line appears without a tagline could help by giving context for someone who wants to add a tagline.

#2 @karmatosed
5 weeks ago

  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I agree with @sabernhardt that this should be closed and as it has sat for a while with that suggestion I am going to action this now. We are currently working out together what the future means for default themes and the focus is on bug fixing, this therefore doesn't fit into that. Thank you everyone for your collaboration, we can always reopen a ticket in the future to focus on this.

Note: See TracTickets for help on using tickets.