WordPress.org

Make WordPress Core

Opened 11 months ago

Closed 3 weeks ago

Last modified 3 weeks ago

#45941 closed defect (bug) (worksforme)

Menu order not saving correctly 5.0.3

Reported by: routram92 Owned by: audrasjb
Milestone: Priority: normal
Severity: normal Version:
Component: Menus Keywords:
Focuses: Cc:
PR Number:

Description

Hi,

I have removed all plugins back to only the classic editor and the issue still persists.

After creating a new menu. I created about 30 custom links all with # as the link since they are temporary placeholders for a client. I then hit save and when I reloaded the page they are all in a mixed up order. When I add a new link to the menu it appears at the bottom of the list as expected, yet when I hit save and reload the page is is mixed in the middle of the links. No matter what, when I re-order them through the standard drag and drop after hitting save they got back to the random order the website saved them as.

No ideas whats causing this and I did a search in here and I couldnt find anyone else reporting this.

I've not experienced this on any of my other wordpress versions.

Change History (4)

#1 @swissspidy
11 months ago

  • Component changed from General to Menus

#2 @audrasjb
11 months ago

  • Keywords reporter-feedback added
  • Owner set to audrasjb
  • Status changed from new to assigned

Hi, welcome to WordPress Trac and thanks for the ticket @routram92 !

I added 5 links with # anchor and diverse Titles, I tried to reorder them in different ways and I can't reproduce the issue (see screenshot below). Please can you test if the issue still happens with a fresh WordPress installation?

#3 @audrasjb
3 weeks ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from assigned to closed

Closing ticket as it looks like the issue doesn't appears on a Core fresh install. Sounds like it's not related to WordPress Core itself.
Feel free to reopen the ticket if you are able to reproduce the issue.

#4 @audrasjb
3 weeks ago

  • Version 5.0.3 deleted
Note: See TracTickets for help on using tickets.