WordPress.org

Make WordPress Core

Opened 3 years ago

Last modified 3 years ago

#45956 closed task (blessed)

Upgrade WPCS to 1.2.1 — at Version 1

Reported by: pento Owned by: pento
Milestone: 5.1 Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: coding-standards Cc:

Description (last modified by pento)

By upgrading WPCS to 1.2.1:

  • Generic.PHP.NoSilencedErrors.Discouraged is replaced by WordPress.PHP.NoSilencedErrors.Discouraged, which whitelists 123 instances of errors being appropriately silenced.
  • Autofix 191 violations of Generic.WhiteSpace.ScopeIndent.
  • Fix 6 false positives in WordPress.WhiteSpace.PrecisionAlignment.Found.
  • The allowMultipleArguments property of PEAR.Functions.FunctionCallSignature defaults to false, so we can remove that custom setting from phpcs.xml.dist.

By upgrading PHPCS to 3.4.1:

  • Fix 23 false positives in Squiz.PHP.DisallowMultipleAssignments.Found

Change History (2)

#1 @pento
3 years ago

  • Description modified (diff)

@pento
3 years ago

Note: See TracTickets for help on using tickets.