WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

#45957 closed defect (bug) (worksforme)

Issue debug message after update to 5.0.3

Reported by: futur3int Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: Cc:

Description

Just updated wp to 5.0.3 and got the following error (debug mode) appearing in the add plugin page from backoffice-> Notice: Undefined property: stdClass::$plugin in /../wp-includes/class-wp-list-util.php on line 150

Seems nothing is impacted by this issue but still i don’t know how to fix it (remove the message).

Is there a fix planed for next wp update?

Any clue?

Change History (5)

#1 @futur3int
8 months ago

Hi, just installed the classic editor back and it seems the issue is no more. So it as to be related to the new gutenberg editor.

#2 @pento
8 months ago

  • Component changed from General to Plugins
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thank you for the bug report, @futur3int!

This notice is caused by the plugin update information cache having incorrect data in it, installing the classic editor plugin will have cleared that cache. Do you still see the problem if you deactivate and remove the classic editor plugin?

The most likely cause of the incorrect data getting into the cache is a paid version of a plugin that updates from a site other than WordPress.org.

See #44582 for more information.

#3 @futur3int
8 months ago

Hi,

I desactivated and also removed the classic editor. The message was gone until today. Meanwhile I reeinstalled the classic editor and activated it. Now whatever im doing the message remains. Any clue? TY

#4 @futur3int
8 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

#5 @futur3int
8 months ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

I managed a fresh install 5.0.3 and installed my website back. Now the message is gone.

Note: See TracTickets for help on using tickets.