WordPress.org

Make WordPress Core

Opened 9 months ago

Last modified 9 months ago

#45980 reopened defect (bug)

WordPress 5.0.3 PDF is opening empty page in Chrome and not showing content

Reported by: Timama Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 5.0.3
Component: Media Keywords: has-screenshots
Focuses: Cc:
PR Number:

Description

Hi,

I have some links that open pdf.
On firefox or safari, when I clic on the link, the pdf is opend on another page.
I can see the pdf.

On Chrome, when I clic, anoter page is open but the page is empty.
I can see on the url that the pdf is open

https://www.....de/wp-content/uploads/2018/07/TEST.pdf

but it is empty. And it worked before (not with WordPress 5.0.1)

And it doesn't work with new pdf too.

MAny thanks for you help

Attachments (1)

pdf.png (309.0 KB) - added by subrataemfluence 9 months ago.

Download all attachments as: .zip

Change History (10)

#1 follow-up: @subrataemfluence
9 months ago

  • Component changed from General to Media
  • Resolution set to invalid
  • Status changed from new to closed

Welcome to trac and thanks for the ticket!

I uploaded a PDF and found no issue opening it fine on both FF ad Chrome. I did not experience any blank screen.

Please try once by clearing your browser cache. Also, are you able to open any other PDFs, not from inside a WordPress application?

Please try to reproduce the issue on fresh WordPress installation.

I am closing this ticket. If if continue to encounter the same issue please reopen and provide more details.

Thank you!

#2 in reply to: ↑ 1 ; follow-up: @Timama
9 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to subrataemfluence:

Many Thanks for your answer.

I clear my Browser Chrome (I have the problem only with Chrome).
But I have still nothing to see.
And I can open with Chrome any other PDF that not come from wordpress.

Does it work for you with this following link? For me, it opens apage but nothing inside

https://programm-maplus.de/wp-content/uploads/2018/03/180213_Flyer_MAplus_FIRMEN_FINAL.pdf

Many thanks for your test

Welcome to trac and thanks for the ticket!

I uploaded a PDF and found no issue opening it fine on both FF ad Chrome. I did not experience any blank screen.

Please try once by clearing your browser cache. Also, are you able to open any other PDFs, not from inside a WordPress application?

Please try to reproduce the issue on fresh WordPress installation.

I am closing this ticket. If if continue to encounter the same issue please reopen and provide more details.

Thank you!

#3 in reply to: ↑ 2 ; follow-ups: @subrataemfluence
9 months ago

Does it work for you with this following link? For me, it opens apage but nothing inside

https://programm-maplus.de/wp-content/uploads/2018/03/180213_Flyer_MAplus_FIRMEN_FINAL.pdf

Yes, I can see the PDF. Please see attached screenshot.
I am sure its something in your browser settings which is preventing you from viewing it.

@subrataemfluence
9 months ago

#4 @subrataemfluence
9 months ago

  • Keywords has-screenshots added

#5 @subrataemfluence
9 months ago

  • Summary changed from WordPress 5.0.3 Chrome only PDF visualisation to WordPress 5.0.3 PDF is opening empty page in Chrome and not showing content

#6 in reply to: ↑ 3 ; follow-up: @Timama
9 months ago

many thanks for this test.

I don't understand why it is not working with this pdf for me.
And as i said, I can open pdf in Chrome, when pdf doens't come from wrodpress.

And i am not the only one to have this problem (the problem just apeared without changing anything in chrome).

Maybe it is an interference with a Plugin.
I am still investigating

Replying to subrataemfluence:

Does it work for you with this following link? For me, it opens apage but nothing inside

https://programm-maplus.de/wp-content/uploads/2018/03/180213_Flyer_MAplus_FIRMEN_FINAL.pdf

Yes, I can see the PDF. Please see attached screenshot.
I am sure its something in your browser settings which is preventing you from viewing it.

#7 in reply to: ↑ 6 @Timama
9 months ago

and i just check, I can see pdf for a pdf oppend from an Old Wordpress (not wordpress 5.0.1 or 3)

Wehn I click on a link, I can poend a pdf and see it in chrome (when it comes from WordPress 4.9.8).

Then, is It really My Chrome parameter that doesn't work ?

I am still investigating

Replying to Timama:

many thanks for this test.

I don't understand why it is not working with this pdf for me.
And as i said, I can open pdf in Chrome, when pdf doens't come from wrodpress.

And i am not the only one to have this problem (the problem just apeared without changing anything in chrome).

Maybe it is an interference with a Plugin.
I am still investigating

Replying to subrataemfluence:

Does it work for you with this following link? For me, it opens apage but nothing inside

https://programm-maplus.de/wp-content/uploads/2018/03/180213_Flyer_MAplus_FIRMEN_FINAL.pdf

Yes, I can see the PDF. Please see attached screenshot.
I am sure its something in your browser settings which is preventing you from viewing it.

#8 in reply to: ↑ 3 @Timama
9 months ago

hi,

My customer can open pdf with Chrome, but not the pdf in my website.

I still think that the problem comes from WordPress 5.0.3, because it was working before.

Replying to subrataemfluence:

Does it work for you with this following link? For me, it opens apage but nothing inside

https://programm-maplus.de/wp-content/uploads/2018/03/180213_Flyer_MAplus_FIRMEN_FINAL.pdf

Yes, I can see the PDF. Please see attached screenshot.
I am sure its something in your browser settings which is preventing you from viewing it.

Last edited 9 months ago by Timama (previous) (diff)

#9 @Timama
9 months ago

Hi

I reinstalled Wordpress 4.9.9 and for the test link above (https://programm-maplus.de/wp-content/uploads/2018/03/180213_Flyer_MAplus_FIRMEN_FINAL.pdf) it is working now.

But it doesn't work with another link as this one
https://www.kmuzentrale.de/wp-content/uploads/2018/10/181023_Netzwerk-Konferenz_Programmheft_FINAL.pdf

So, reinstalling an old wordpress version had changed someting for some pdf but not all pdf.

Does someone can open the pdf in the folowing link ?
https://www.kmuzentrale.de/wp-content/uploads/2018/10/181023_Netzwerk-Konferenz_Programmheft_FINAL.pdf

many thanks for your help

Note: See TracTickets for help on using tickets.