WordPress.org

Make WordPress Core

Opened 23 months ago

Closed 2 months ago

#45992 closed defect (bug) (reported-upstream)

Pressing delete key within a paragraph containing an anchor deletes the anchor (Firefox)

Reported by: greatislander Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0.3
Component: Editor Keywords:
Focuses: Cc:

Description

When editing a paragraph containing an anchor (e.g.
<a id="test"></a>) in Firefox (64.0.2, macOS 10.14.2), pressing the delete key to delete any text in the paragraph removes the anchor, regardless of the position of the cursor in relation to the anchor within the paragraph. This affects:

  • Classic Editor
  • Gutenberg (Classic Block)
  • Gutenberg (Paragraph)

This behaviour occurs with WordPress 5.0.3, with and without the Classic Editor plugin installed. I cannot reproduce the issue in Chrome or Safari.

Demo videos:

Change History (1)

#1 @noisysocks
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Moved this to the Gutenberg GitHub repository which is where development of the block editor happens.

https://github.com/WordPress/gutenberg/issues/25598

Note: See TracTickets for help on using tickets.