WordPress.org

Make WordPress Core

#46009 closed enhancement (reported-upstream)

Listing block improvement - make Shift Enter work like in paragraphs

Reported by: hanheg Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0.3
Component: Editor Keywords:
Focuses: Cc:
PR Number:

Description

Many users use Shift - Enter in a listing. For instance when you have a set of terms with an explanation. You want the terms after the bullet and than on a new line an explanation. That is not possible in the listing block because a Shift Enter does the same as Enter. It starts a new bullet.
It would be great if you could use Shift Enter to start a new line within a bullet.
Just like it works in the paragraph block.
And by the way also in the Classic editor block listings.

Change History (1)

#1 @swissspidy
12 months ago

  • Component changed from General to Editor
  • Keywords 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Closing as a duplicate of https://github.com/WordPress/gutenberg/issues/11215, because this was reported upstream a while ago and we can keep discussions at one place this way.

URL: https://github.com/WordPress/gutenberg/issues/11215

Note: See TracTickets for help on using tickets.