WordPress.org

Make WordPress Core

Opened 8 months ago

Last modified 8 months ago

#46016 new defect (bug)

Unable to move blocks in editor

Reported by: Sophie_Kath Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 5.0.3
Component: Editor Keywords: has-screenshots
Focuses: Cc:

Description

As I understand it: an active block can be moved up or down with arrows at the left of the block, which appear with mouse pointer hover.

Arrows do not appear with hover.

When I highlight two blocks (click & drag), I can see the arrows and moving works. However, there is no handle for dragging.

OS: windows 10

Browser: chrome

wp: v. 5.0.3

Theme: Twenty Seventeen (version is up-to-date)

  • Jon

Change History (2)

#1 @mukesh27
8 months ago

  • Component changed from General to Editor
  • Keywords needs-screenshots reporter-feedback added

Hi @Sophie_Kath, Welcome to WordPres Trac! Thanks for the report.

Does the issue happen with all plugins disabled and a default theme (Twenty Nineteen) activated?

Can you please share screenshot and steps to replicate issue.

#2 @Sophie_Kath
8 months ago

  • Keywords has-screenshots added; needs-screenshots reporter-feedback removed

@mukesh27

The following screen shots are from the Twenty Seventeen theme. Behavior in the editor was the same in the Twenty Nineteen theme. All plugins are inactive.

https://picturemichigan.com/photography/wp-content/uploads/2019/01/a-1.jpg

https://picturemichigan.com/photography/wp-content/uploads/2019/01/b-1.jpg

https://picturemichigan.com/photography/wp-content/uploads/2019/01/c-1.jpg

https://picturemichigan.com/photography/wp-content/uploads/2019/01/d-1.jpg

https://picturemichigan.com/photography/wp-content/uploads/2019/01/e-1.jpg

https://picturemichigan.com/photography/wp-content/uploads/2019/01/f-1.jpg


img A shows the tree structure of the blocks in this test post.

img B shows an active text block with the add-block plus symbol in a circle. It appears with hover, but move arrows do not appear with any amount of pointer hover. (demonstrating that the hover function for the editor works).

img C shows two highlighted blocks. Click/drag cursor over two blocks to highlight. Or shift/click to highlight. Curiously, ctrl/click does not highlight. Arrows appear, and they do work. But there is no handle to drag. (The arrows appear without any hover interaction.)
img D shows the text in a column highlighted with no arrows.

img E shows the entire column highlighted with arrows showing, but the arrows do not work.

img F shows the column block and a text box highlighted, showing arrows that do work.

Hopefully it's enough info without being too much.

DISCLAIMER: I'm just a DIY guy maintaining my own website. Not a coder. I updated to WP5.0 having no idea of the rabbit hole leading to Wonderland! I do want to express that I do like the new block system!

  • Jon
Note: See TracTickets for help on using tickets.