WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 4 months ago

#46037 closed defect (bug) (duplicate)

Fix URL creating in class-wp-list-table in wp-admin

Reported by: tinodjwp Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

At line 1009 and 1010 in wp-admin/includes/class-wp-list-table.php URL is created in the following way:

<?php



                $current_url = set_url_scheme( 'http://' . $_SERVER['HTTP_HOST'] . $_SERVER['REQUEST_URI'] );
                $current_url = remove_query_arg( 'paged', $current_url);

This makes troubles in some scenarios. Recommended way is to replace these two lines, by one line :

<?php
                $current_url = site_url(remove_query_arg( 'paged'));

Change History (4)

#1 @tinodjwp
7 months ago

  • Component changed from General to Administration

#2 @tinodjwp
7 months ago

Please also see #46033, maybe there are other places this needs to be fixed.

#3 @tinodjwp
7 months ago

Very similar things should be fixed in function pagination, which starts at line 711.

#4 @ocean90
4 months ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 5.0.3 deleted

Duplicate of #36201.

Note: See TracTickets for help on using tickets.