WordPress.org

Make WordPress Core

Opened 2 years ago

Last modified 9 months ago

#46059 new defect (bug)

cyrillic capitalization in tag search

Reported by: anonymized_15879810 Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: I18N Keywords: reporter-feedback
Focuses: Cc:

Description

When doing search tags using Cyrillic if you didn't guess right capitalization in existing tag, then it won't be in search result. It's impossible to find all tags with given substring if they are saved with different capitalization in this substring.

Change History (3)

#1 @sabernhardt
13 months ago

  • Component changed from General to I18N
  • Keywords reporter-feedback added

@searoso Hi and thanks for the report!

Do you have this problem within the post editor, or does it occur on the Tags listing page? Or does it happen on both of those?

And if it occurs in the post editor, are you using the Block Editor or the Classic Editor?

#2 @anonymized_15879810
13 months ago

Don't remember about editor. But I definitely tried to create tags of different capitalization in Latin and in Cyrillic. And then tried to search it (I believe I used just on-site search). Latin returned, while Cyrillic needed precise match. (Maybe it was Tags listing though.)

#3 @pauljacobson
9 months ago

Hi @sabernhardt and @searoso

I'm a Happiness Engineer at WordPress.com, and I believe I've come across a variant of this issue. The user explained that when they change the capitalization of a letter in the search widget on their site, the search results differ.

Specifically, they searched using the words Кофе and кофе. They indicated that this was a mobile issue, but I was able to reproduce the issue when viewing the site in my desktop browser.

The site is currently using the Profile theme - https://wordpress.com/theme/profile

I ran the search using the Search Widget available through the Customizer.

I tested this using Firefox Developer Edition v79.0b9, as well as Brave Version 1.11.97 Chromium: 84.0.4147.89 on macOS 10.15.6.

This issue seems to be related to #31728 too.

Our reference for any follow-up is 3118235-zen.

Last edited 9 months ago by pauljacobson (previous) (diff)
Note: See TracTickets for help on using tickets.