WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#4608 closed enhancement (wontfix)

HTML and Javascript Formatting

Reported by: nawingee Owned by:
Milestone: Priority: high
Severity: major Version:
Component: Administration Keywords:
Focuses: Cc:

Description

Hi,
I am new to the world of wordpress. I am using wordpress-mu 1.2.1 version installed. Below is the difficulty i face.

” I had issues posting HTML(source includes javascript)into wordpress. Wordpress wants to format the html after we post an article. Even if we only use the “Code” tab(enableing Rich Text Editor), the wordpress system will try to format what was pasted in. Here are some examples of the formatting:
formats out javascript tags
adds <br/> after each carriage return
changes — to –

Please look into creating a plugin that will bypass *all* the formatting when we post an article through the Code tab.”

We tried with Text control Plugin http://dev.wp-plugins.org/wiki/TextControl (which allows javascript inside posts). But when i tried, the <script> tag still gets removed and the page looks altered. Also i tried with Text Control option "MarkDown". at it throwed the error "Warning: preg_replace_callback() [function.preg-replace-callback]: Unknown modifier '|'".

Please Suggest if Text control plugin solves this need and if not Please suggest some sollution for it. It's highly important for me.

Thanks

Change History (1)

comment:1 Nazgul7 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

This is more a support issue than a bug/feature request.

The formating is (partly) done by the wpautop filter and is by design. If you don't want it to format your code, you could take a look at:
http://urbangiraffe.com/plugins/disable-wpautop/

For further help/information i'd suggest:
http://wordpress.org/support/

Note: See TracTickets for help on using tickets.