WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#46084 closed enhancement (duplicate)

Sunset Gravatar as the default option for profile image

Reported by: mor10 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Users Keywords:
Focuses: administration, privacy Cc:

Description

To add a user profile photo to a WordPress site without adding a plugin, the user has to create a Gravatar. Creating a Gravatar requires a WordPress.com account. This requires the user of a self-hosted WordPress site to have a WordPress.com account to use a core feature.

Gravatar is a great idea and a great service. However, having a WordPress.com account should not be a prerequisite to use a core feature, especially something as central and expected as a user profile photo. In my opinion.

Having Gravatar be the only core option for user profile pictures introduces several issues including (but not limited to):

  • Having to have a WordPress.com account.
  • No access to WordPress.com or Gravatar.com from intranets and systems not connected to the web or behind firewalls or geoblockers that block either domain.
  • Data collection and privacy concerns (real and/or imagined) around what it means to upload a photo to Gravatar.com / create an account on WordPress.com. (see #45384 as example)

Proposal

  • Introduce a core option to use profile photo from media library.
  • Sunset Gravatar as core option. Offer Gravatar as plugin.
  • Introduce Gravatar-type service not tied to WordPress.com (ideally hosted by WordPress.org or similar).

Change History (5)

#1 @garrett-eclipse
2 years ago

  • Component changed from General to Users
  • Focuses administration privacy added

#2 @earnjam
2 years ago

Related #14682

#3 follow-up: @earnjam
2 years ago

Actually, this is sort of a combination of #14682 and #16020. Could probably close as a duplicate.

#4 in reply to: ↑ 3 @glueckpress
2 years ago

Replying to earnjam:

Actually, this is sort of a combination of #14682 and #16020. Could probably close as a duplicate.

Although essentially about the same topic, this one here is worded a lot more thorough than #16020 where the author just said ‘it would be nice if’. Closing it as a duplicate would remove its coherent reasoning from visibility.

Version 1, edited 2 years ago by glueckpress (previous) (next) (diff)

#5 @ocean90
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing it as duplicate of #44067, #14682 and #16020 which already have some history and actionable suggestions.

Note: See TracTickets for help on using tickets.