WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 9 months ago

#46164 closed defect (bug) (fixed)

Fix editor.css to properly override all default TinyMCE styles from skin.min.css

Reported by: azaozz Owned by: azaozz
Milestone: 5.1 Priority: normal
Severity: normal Version: 5.0
Component: TinyMCE Keywords:
Focuses: Cc:
PR Number:

Description

The editor.css stylesheet is meant to override some of the default TinyMCE UI styling. It is loaded last in Classic Editor (mid-page, after we know there is an editor there), but in the Block Editor it is loaded in the head. That exposes few selectors in editor.css that still depend on the loading order.

Attachments (2)

46164.diff (20.2 KB) - added by azaozz 9 months ago.
46164.1.diff (1.9 KB) - added by azaozz 9 months ago.

Download all attachments as: .zip

Change History (7)

#1 @azaozz
9 months ago

  • Milestone changed from Awaiting Review to 5.1

There are few (mostly visual) bugs in the Classic Block because of that, see: https://github.com/WordPress/gutenberg/pull/10281.

Will try to patch it before 5.1-RC :)

Last edited 9 months ago by azaozz (previous) (diff)

@azaozz
9 months ago

#2 @azaozz
9 months ago

In 46164.diff: make the selectors in editor.css slightly more specific. Fixes styling problems in the Classic Block where editor.css is loaded early.

#3 @azaozz
9 months ago

Thinking more about this, currently for the Classic Block we do overrides of the overrides of the default TinyMCE styles. Best would be to fix/refactor editor.css to remove all these "second level" overrides. Opened https://core.trac.wordpress.org/ticket/46173 for that.

This ticket should focus only on fixing known bugs in the Classic Block styling for 5.1. Patch coming up.

@azaozz
9 months ago

#4 @azaozz
9 months ago

In 46164.1.diff: fix (visual) regressions in the Classic Block TinyMCE drop-down menu colors.

#5 @azaozz
9 months ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 44724:

TinyMCE: fix color of highlighted drop-down menu items in Classic Block.

Fixes #46164.

Note: See TracTickets for help on using tickets.