Make WordPress Core

Opened 5 years ago

Closed 11 months ago

#46165 closed defect (bug) (worksforme)

Twenty Seventeen's dark theme issue with code blocks

Reported by: ahmadalli's profile ahmadalli Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0.3
Component: Bundled Theme Keywords: has-patch has-screenshots
Focuses: ui Cc:

Description

there's a section on css containing

body.colors-dark, .colors-dark button, .colors-dark input, .colors-dark select, .colors-dark textarea, .colors-dark h3, .colors-dark h4, .colors-dark h6, .colors-dark label, .colors-dark .entry-title a, .colors-dark.twentyseventeen-front-page .panel-content .recent-posts article, .colors-dark .entry-footer .cat-links a, .colors-dark .entry-footer .tags-links a, .colors-dark .format-quote blockquote, .colors-dark .nav-title, .colors-dark .comment-body {
    color: #eee;
}

the selector also must include

.colors-dark code

Attachments (2)

46165-before-after.png (477.9 KB) - added by metodiew 4 years ago.
Before After image
46165.diff (473 bytes) - added by metodiew 4 years ago.

Download all attachments as: .zip

Change History (5)

#1 @williampatton
5 years ago

  • Component changed from Themes to Bundled Theme
  • Keywords needs-screenshots needs-patch added

@metodiew
4 years ago

Before After image

@metodiew
4 years ago

#2 @metodiew
4 years ago

  • Keywords has-patch has-screenshots added; needs-screenshots needs-patch removed

This seems to be a fairly small fix - one line of CSS. You can see the before-after version in the attached image.

#3 @poena
11 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Severity changed from major to normal
  • Status changed from new to closed

Reproduction Report

This report validates that the issue can not be reproduced.

Environment

  • OS: Win 10
  • Web Server: Nginx
  • PHP: 8.0.22
  • WordPress: 6.2
  • Browser: Chrome, Firefox
  • Theme: Twenty Seventeen Version: 3.2
  • Active Plugins: None

Actual Results

  • ✅ Error condition does not occur.

Additional Notes

After enabling the dark color scheme in the customizer:
-The classic block with code inside displays the code in light grey color: #eee;
-The code block displays the code in light grey color: #eee;
-Code added with the old classic editor, before 5.0: the code displays in a light grey color: #eee
(this content was tested with the help of the post "Markup: HTML Tags and Formatting" in the theme test data.

Note: See TracTickets for help on using tickets.