WordPress.org

Make WordPress Core

Opened 10 months ago

Closed 10 months ago

Last modified 9 months ago

#46172 closed defect (bug) (duplicate)

Numeric permalinks have "-2" added

Reported by: neonkowy Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Permalinks Keywords:
Focuses: Cc:
PR Number:

Description

Hey, I have strange behaviour from last update:

  1. create a new page with any title
  2. save draft
  3. set permalink to some number (e.g. /9000)
  4. save page
  5. you'll see that permalink has changed to 9000-2 -> when entering /9000 you'll be 301 redirected to /9000-2

It's the same in editor (Gutenberg) and in quick edit, so I assume that's a core issue.

See more here: https://github.com/WordPress/gutenberg/issues/13508

Change History (4)

#1 @ocean90
10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14238 and #5305.

#2 @neonkowy
10 months ago

Can someone tell me how is this possible that I have my previous posts working as numeric: see https://www.braciaprzykawie.pl/007/ or https://www.braciaprzykawie.pl/001

And the problem somehow showed up with https://www.braciaprzykawie.pl/008? I managed to change permalink manually in database so it's working for now - unfortunately every edit it seems to change it to /008-2

I see that issue is here for 11 years! What's the current status?

#3 @ocean90
10 months ago

The status is the same, numeric-only slugs are not supported as of [13424]/#11917. If you think they are working on your site you can give https://wordpress.org/plugins/allow-numeric-stubs/ a try.

#4 @neonkowy
10 months ago

You're proposing me outdated plugin. Well, I hope that this behaviour is documented for next ones.

Last edited 9 months ago by neonkowy (previous) (diff)
Note: See TracTickets for help on using tickets.