WordPress.org

Make WordPress Core

#46189 closed defect (bug) (reported-upstream)

Permalink generator way less picky with the new editor

Reported by: billium99 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

I have a title: 161: Acute Problems - What To Do

The permalink of old would have been "161-acute-problems-what-to-do"

But just now, I'm getting "161:-acute-problems---what-to-do"

Change History (2)

#1 @earnjam
18 months ago

Hi @billium99 and welcome to WordPress Trac!

Are the slugs saving that way when you publish, or are they just displaying within the editor that way?

There are some current efforts to improve how the permalink is displayed within the editor:
https://github.com/WordPress/gutenberg/pull/13551
https://github.com/WordPress/gutenberg/pull/12009

But underneath it uses the same method of actually saving, so it shouldn't be any different than the old editor when published.

#2 @andraganescu
16 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from assigned to closed

The editor does exhibit the same behaviour today. I have opened on GitHub a ticket specifically for the issue raised by @billium99 that is that some chars are not replaced anymore in the slug generation.

I have switched and tested on the try/improve-permalink-editing branch of Gutenberg https://github.com/WordPress/gutenberg/pull/12009 and that does not fix this issue.

I will close it here and continue on the Gutenberg GitHub repo's new Issue about this here https://github.com/WordPress/gutenberg/issues/15141

Note: See TracTickets for help on using tickets.