WordPress.org

Make WordPress Core

Opened 10 months ago

Closed 10 months ago

Last modified 10 months ago

#46268 closed defect (bug) (invalid)

add to menu button not working

Reported by: mohamedh Owned by:
Milestone: Priority: normal
Severity: major Version:
Component: General Keywords: needs-patch
Focuses: Cc:
PR Number:

Description

Hi,

I recently started to use php 5.6 with wp (it doesn't matter if it's clean wp installation or an old one) and I ran into a problem. When adding new items to navigation menu, the “add to menu” doesn’t work. This video illustrates my problem: https://drive.google.com/file/d/1hEa2lNkavCm-EFfU7Ct8c88LOhRH9vl1/view

I tried changing these in my php.ini

<?php

post_max_size 20M
max_input_vars 10000

But it didn't solve the issue.

I tried clearing my browser cache and emptying the .htaccess file and I already have the following in my wp-config right before "that's all stop editing"

<?php
define('WP_DEBUG', true);
define( 'CONCATENATE_SCRIPTS', true );

define( 'WP_MEMORY_LIMIT', '256M' );

I tried to reproduce the issue on a test server with different versions and I figured that the problem occurs when upgrading from centos 7's default php 5.4 to php v5.6.40. It doesn't matter if the php version is updated after installing wordpress or before. I tried Upgrading to php7 and it solved the issue. Then I downgraded back to php 5.40 and everything was still working.

Change History (3)

#1 follow-up: @mohamedh
10 months ago

sorry at the end I meant: downgraded back to php 5.6.40 (not 5.40)*

Last edited 10 months ago by mohamedh (previous) (diff)

#2 in reply to: ↑ 1 @mohamedh
10 months ago

  • Resolution set to invalid
  • Status changed from new to closed

I figured it out. It's not a Wordpress bug.

The problem was Suhosin. Suhosin v 0.9.37 was the culprit.
I upgraded to version 0.9.38 following these: http://forums.sentora.org/showthread.php?tid=4131&pid=30287#pid30287

#3 @desrosj
10 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.