WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#46299 closed defect (bug) (fixed)

jshint.js returning 404

Reported by: desrosj Owned by: jorbin
Milestone: 5.1 Priority: normal
Severity: normal Version: 5.1
Component: Script Loader Keywords: has-patch commit dev-reviewed
Focuses: javascript Cc:

Description

When using the Customizer or widgets pages, the wp-includes/js/codemirror/jshint.js file returns a 404.

Props @afercia for finding and @mensmaximus for testing.

Attachments (1)

46299.diff (1020 bytes) - added by jorbin 4 months ago.

Download all attachments as: .zip

Change History (6)

@jorbin
4 months ago

#1 @jorbin
4 months ago

  • Keywords has-patch added; needs-patch removed

This ticket was mentioned in Slack in #core by jorbin. View the logs.


4 months ago

#3 @pento
4 months ago

  • Keywords commit dev-reviewed added
  • Version set to trunk

Tested and confirmed that 46299.diff fixes the 404 errors.

Also compared to [44163], this undoes the accidental revert.

#4 @jorbin
4 months ago

  • Owner set to jorbin
  • Resolution set to fixed
  • Status changed from new to closed

In 44762:

Script Loader: Load fakejshint as jshint due to "good and evil".

Originally fixed in [42547]. Broken in [44163]. We've been here before. I recognize that tree.

Fixes #46299

#5 @jorbin
4 months ago

In 44763:

Script Loader: Load fakejshint as jshint due to "good and evil".

Backports [44762] from trunk to 5.1. Devreviewed by Pento.

Originally fixed in [42547]. Broken in [44163]. We've been here before. I recognize that tree.

Fixes #46299

Note: See TracTickets for help on using tickets.