WordPress.org

Make WordPress Core

Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#46332 closed defect (bug) (invalid)

No way to close an image opened from a blog post

Reported by: Rolf Broberg Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

Using WordPress 5.1 (and theme Twenty Ten).

When clicking on an image in a blog post, the image is shown without an (x) button, does not respond to [esc] or clicking/double clicking in or beside the image to close it. The only way I can close is using tne "back" button in my web browser (FF). My images use link to "media file", not to "attachments page" or whatever you call that option in English.

Change History (5)

#1 @Rolf Broberg
18 months ago

Test example: Click on one of the images i my blog post
http://trafikistan.se/centralenomradet-per-cykel/

#2 @knutsp
18 months ago

  • Keywords close added

Hello and elcome to Trac, Rolf.

This seems to be the expected behavior in Twenty Ten. When the click is not intercepted by a script (ex. lightbox) the browser navigates to the bare image file url.

See also https://2010dev.wordpress.com/

Last edited 18 months ago by knutsp (previous) (diff)

#3 @Rolf Broberg
18 months ago

I updated Twenty Ten to latest version today, and I'm quite sure that images had a way of closing before that. Am I wrong about that?

#4 @knutsp
18 months ago

  • Component changed from General to Bundled Theme
  • Keywords close removed
  • Resolution set to invalid
  • Status changed from new to closed

Sorry. Just tested with a fresh installation.

When you open the file link you actually leave WordPress. A lightbox, or similar, plugin, or a theme equipped with such, will intercept it and open a box with the image resized to the screen size and a close button.

Please try support https://wordpress.org/support/ if you need help with your site.

#5 @desrosj
18 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.