WordPress.org

Make WordPress Core

Opened 20 months ago

Closed 19 months ago

Last modified 19 months ago

#46345 closed defect (bug) (invalid)

Pagination in WP Admin for posts is not working

Reported by: stevem9999 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: General Keywords:
Focuses: administration Cc:

Description

I have over 100 posts and the post list page in WP admin shows 20 at a time. However, when I click to go to the next page, it repeats some of the same posts on the second page. If I click next page again, it repeats them again. If I page all the way to the end, some posts are never seen. The only way I can find them is by searching.

As background, I started this site (not live yet) on 5.0 and had the issue. I upgraded to 5.1 and still see the issue.

Change History (6)

#1 follow-up: @mukesh27
20 months ago

  • Focuses administration added
  • Keywords reporter-feedback added

Hi @stevem9999, Welcome to WordPres Trac! Thanks for the report.

Does the issue still happen with all plugins disabled and a default theme (Twenty Nineteen) activated?

i can't replicate above issue in fresh install WordPress 5.1

#2 in reply to: ↑ 1 @stevem9999
20 months ago

Replying to mukesh27:

Hi @stevem9999, Welcome to WordPres Trac! Thanks for the report.

Does the issue still happen with all plugins disabled and a default theme (Twenty Nineteen) activated?

i can't replicate above issue in fresh install WordPress 5.1

Hello - The only plugins I have enabled are Akismet Anti-Spam and Hello Dolly. My theme is "Bootstrap News".

I'm not sure if this would cause it, but I'm building this as a new site by converting data from an old site. In doing so, I created over 100 posts with the same publish date/time, using wp_insert_post from a php script. I just thought I'd let you know.

Last edited 20 months ago by stevem9999 (previous) (diff)

#3 @stevem9999
20 months ago

I tried it with the Twenty Nineteen theme. Also, I realize the 2 plugins I have are not activated. The issue still exists with this default.

#4 @desrosj
20 months ago

  • Keywords close added

@stevem9999 I am unable to reproduce this issue with WordPress 5.0 or 5.1.

When you click to the next page, is that reflected in the pagination navigation (shows 2 of x pages, for example)?

My hunch is that your PHP script, so I am marking as a candidate for closing. When creating posts, your script may be creating posts with the same title (you stated it creates them with the same publish dates/times), and they actually are paginating correctly but don't appear to be changing.

Can you confirm that the post IDs change when you navigate through the pages of posts?

#5 @stevem9999
19 months ago

  • Resolution set to invalid
  • Status changed from new to closed

I'm closing this issue as I don't think it's a problem. I had multiple posts by the same name and I think I got confused when paging.

#6 @desrosj
19 months ago

  • Keywords reporter-feedback close removed
  • Milestone Awaiting Review deleted

Thanks for following up, @stevem9999!

Note: See TracTickets for help on using tickets.