WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#46378 closed defect (bug) (invalid)

html line break does not work

Reported by: mbbrown Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: reporter-feedback close
Focuses: Cc:

Description

I am trying to force line breaks for lines of text within an <address> tag or <p> tag.

I would like my content to appear like this on the page (example 1):

University of Oulu
Pentti Kaiteran katu 1
90014 Oulu, Finland

Instead of like this (example 2):

University of Oulu Pentti Kaiteran katu 1 90014 Oulu, Finland

When I add a <br> tag using the html code editor and update the page, the <br> tag disappears and fails to affect the appearance of the content (see example 2 above). The same thing happens when I use a <p> tag for each line of text: the <p> tag disappears in the html code editor, and my text appears on the page like example 2.

Change History (5)

#1 follow-up: @Presskopp
3 years ago

Hello,

I cannot reproduce this. Are you using the block editor or are you inside a widget? Please use a standard theme and no external plugins and try again. If it still happens please let us know how to reproduce exactly. Thank you.

#2 @Presskopp
3 years ago

  • Keywords reporter-feedback added

#3 in reply to: ↑ 1 @mbbrown
3 years ago

Replying to Presskopp:

I had not yet read about how to use the block editor, and I was writing html in it the way I had been in versions of WordPress prior to 5.0. I was not inside a widget, and the theme of my website is Vantage. My web designer found a plugin called "Classic Editor" that allowed me to create pages and write in html the way I had done in the past. Returning to this editing method "fixed" the issue, and p & br tags now work the way I was used to.

#4 @Presskopp
3 years ago

  • Keywords close added
  • Resolution set to invalid
  • Status changed from new to closed

#5 @desrosj
3 years ago

  • Milestone Awaiting Review deleted
  • Version 5.1 deleted
Note: See TracTickets for help on using tickets.