WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 8 months ago

Last modified 8 months ago

#46383 closed defect (bug) (reported-upstream)

All Media Items Filtering Missing

Reported by: jbph Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:
PR Number:

Description

At the top of Grid View, it was possible to filter the media by media type and date:
All media items

This dropdown allows you to select, by media type such as Images, Audio and Video or Unattached to any Posts nor Pages, which Media are displayed in the Table of Media. By default, “All media items” is selected and all of your Media are displayed.

This Option appears to have been left out since Gutenberg has been introduced making the management of thousands of media items impossible.

Attachments (1)

Add-Media-NOT-Working-5.1.jpg (93.8 KB) - added by jbph 8 months ago.

Download all attachments as: .zip

Change History (5)

#1 @desrosj
8 months ago

  • Keywords close reporter-feedback added; needs-patch removed

Hi @jbph,

Thanks for opening this ticket, and welcome to Trac!

I am unable to reproduce the issue that you are describing in my testing. I see the All Media Items and All Dates dropdowns on both the grid and list views of the media library.

Can you confirm that you are talking about the wp-admin/upload.php page and not a modal that is accessible through the block editor?

Can you also see if you still experience the issue with all plugins disabled?

I am marking this as a candidate for closure because it is working for me, and there have been no other reports of this issue so far. I think it is an issue with your specific setup.

#2 @jbph
8 months ago

  • Keywords close removed

Hi @desrosj,

I have added an image to clarify.

I am talking about a modal through the block editor. So when trying to add an image to a post or page.

I have tried to activate twenty-nineteen and disabled all plugins and the issue is still there. I am sure you can reproduce it too.

#3 @desrosj
8 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Ah! Thanks, @jbph. I see your issue now.

This is an issue that has already been reported and is being worked on in the Gutenberg repository. You can follow along and add any additionals there: https://github.com/WordPress/gutenberg/issues/8748.

If in the mean time you need to make use of this dropdown in your day to day, the dropdown is still present when inserting media while using the Classic Editor block.

#4 @jbph
8 months ago

Thank you @desrosj I am glad to see it is being looked at!

Note: See TracTickets for help on using tickets.